Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19010

hudson.security.AccessDeniedException2: anonymous is missing the Overall/Read permission

    XMLWordPrintable

Details

    Description

      Without assign any permission to anonymous user i clicked on save button
      now i try to run jenkins i can see only bug
      like
      hudson.security.AccessDeniedException2: anonymous is missing the Overall/Read permission

      Please anyone is there who faced same problem give me solution ASAP
      your reply will be appreciate.

      Attachments

        Activity

          deepjain deep jain added a comment -

          Follow this, you will be fine.

          Stop Jenkins (the easiest way to do this is to kill the servlet container.)
          Go to $JENKINS_HOME in the file system and find config.xml file.
          Open this file in the editor.
          Look for the <useSecurity>true</useSecurity> element in this file.
          Replace true with false
          Remove the elements authorizationStrategy and securityRealm
          Start Jenkins
          When Jenkins comes back, it's in the unsecured mode where everyone gets full access to the system.

          If this is still not working, trying renaming or deleting config.xml.

          deepjain deep jain added a comment - Follow this, you will be fine. Stop Jenkins (the easiest way to do this is to kill the servlet container.) Go to $JENKINS_HOME in the file system and find config.xml file. Open this file in the editor. Look for the <useSecurity>true</useSecurity> element in this file. Replace true with false Remove the elements authorizationStrategy and securityRealm Start Jenkins When Jenkins comes back, it's in the unsecured mode where everyone gets full access to the system. If this is still not working, trying renaming or deleting config.xml.
          nicks9188 Nicketa Kumar added a comment -

          Thanks for the resolution. That worked. But what to do after that. It is not letting me login. If I do so, it gives me the error:

           

          PLEASE HELP

          nicks9188 Nicketa Kumar added a comment - Thanks for the resolution. That worked. But what to do after that. It is not letting me login. If I do so, it gives me the error:   PLEASE HELP

           

          nicks9188 struggling with the same setup in Ubuntu 18.10. Care to share how you resolved this? 

          Thanks.

          shimanyi Shimanyi Valentino added a comment -   nicks9188 struggling with the same setup in Ubuntu 18.10. Care to share how you resolved this?  Thanks.
          nicks9188 Nicketa Kumar added a comment -

          As stated by deepjain first you need to disable the security. https://issues.jenkins-ci.org/browse/JENKINS-19010?focusedCommentId=185573&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-185573

           

          After that you need to check or configure username and password. Once done, have to enable the security again. Try to login now with the username and password you just configured.

          nicks9188 Nicketa Kumar added a comment - As stated by deepjain first you need to disable the security.  https://issues.jenkins-ci.org/browse/JENKINS-19010?focusedCommentId=185573&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-185573   After that you need to check or configure username and password. Once done, have to enable the security again. Try to login now with the username and password you just configured.
          nicks9188 Nicketa Kumar added a comment -

          Further there are different types of security available on jenkins. Refer to https://wiki.jenkins.io/display/JENKINS/Standard+Security+Setup for configuration. 

          nicks9188 Nicketa Kumar added a comment - Further there are different types of security available on jenkins. Refer to  https://wiki.jenkins.io/display/JENKINS/Standard+Security+Setup  for configuration. 
          bo3bber Bo3b Johnson added a comment -

          I was getting the same error after resetting the security.

          The piece I was missing is that you also need to set the Security Realm back to "Jenkins' own user database"

          Without that, you get the 403 no valid crumb error.

          bo3bber Bo3b Johnson added a comment - I was getting the same error after resetting the security. The piece I was missing is that you also need to set the Security Realm back to "Jenkins' own user database" Without that, you get the 403 no valid crumb error.

          People

            deepjain deep jain
            mohsin_khan92 Mohsin Khan
            Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: