Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19104

Upgraded to 1.526 and slave nodes won't start

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      I upgraded to the 1.526 build of Jenkins and the slave nodes won't start now. I am seeing the following errors:
      [08/07/13 08:53:08] [SSH] Opening SSH connection to jenkins.nj3.picsorganizer.com:22.
      ERROR: Unexpected error in launching a slave. This is probably a bug in Jenkins.
      java.lang.NoSuchMethodError: com.cloudbees.jenkins.plugins.sshcredentials.SSHAuthenticator.newInstance(Ljava/lang/Object;Lcom/cloudbees/jenkins/plugins/sshcredentials/SSHUser;)Lcom/cloudbees/jenkins/plugins/sshcredentials/SSHAuthenticator;
      at hudson.plugins.sshslaves.SSHLauncher.openConnection(SSHLauncher.java:949)
      at hudson.plugins.sshslaves.SSHLauncher.launch(SSHLauncher.java:488)
      at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:230)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
      at java.util.concurrent.FutureTask.run(FutureTask.java:166)
      at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
      at java.lang.Thread.run(Thread.java:722)
      [08/07/13 08:53:09] [SSH] Connection closed.

        Attachments

          Issue Links

            Activity

            Hide
            stephenconnolly Stephen Connolly added a comment -

            Upgrading to ssh-credentials 1.1 should fix this issue for you. You can download it immediately from http://jenkins-updates.cloudbees.com/download/plugins/ssh-credentials/ or wait the 8-12 hours for it to show up in the update cebter

            Show
            stephenconnolly Stephen Connolly added a comment - Upgrading to ssh-credentials 1.1 should fix this issue for you. You can download it immediately from http://jenkins-updates.cloudbees.com/download/plugins/ssh-credentials/ or wait the 8-12 hours for it to show up in the update cebter
            Hide
            stephenconnolly Stephen Connolly added a comment -

            ssh-slaves 1.1 is no harm but only change is to require ssh-credentials 1.1 as a baseline to help everyone end up with a healed experience.

            You can download it manually from http://jenkins-updates.cloudbees.com/download/plugins/ssh-slaves/

            Show
            stephenconnolly Stephen Connolly added a comment - ssh-slaves 1.1 is no harm but only change is to require ssh-credentials 1.1 as a baseline to help everyone end up with a healed experience. You can download it manually from http://jenkins-updates.cloudbees.com/download/plugins/ssh-slaves/
            Hide
            stephenconnolly Stephen Connolly added a comment -

            Fixed in ssh-credentials 1.1

            Show
            stephenconnolly Stephen Connolly added a comment - Fixed in ssh-credentials 1.1
            Hide
            jgriffithpics Jared Griffith added a comment -

            Yup that fixed it. Awesome, thanks!

            Show
            jgriffithpics Jared Griffith added a comment - Yup that fixed it. Awesome, thanks!
            Hide
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Jesse Glick
            Path:
            src/main/java/com/cloudbees/jenkins/plugins/sshcredentials/SSHAuthenticator.java
            http://jenkins-ci.org/commit/ssh-credentials-plugin/ab2a63259d4e2f8138c8d796095b8043e1febcff
            Log:
            [FIXED JENKINS-19104] Restoring deprecated constructor to avoid NoSuchMethodError when not all plugins were upgraded in synch.

            Show
            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Jesse Glick Path: src/main/java/com/cloudbees/jenkins/plugins/sshcredentials/SSHAuthenticator.java http://jenkins-ci.org/commit/ssh-credentials-plugin/ab2a63259d4e2f8138c8d796095b8043e1febcff Log: [FIXED JENKINS-19104] Restoring deprecated constructor to avoid NoSuchMethodError when not all plugins were upgraded in synch.

              People

              Assignee:
              stephenconnolly Stephen Connolly
              Reporter:
              jgriffithpics Jared Griffith
              Votes:
              1 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: