Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-1921

Too many open files

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Duplicate
    • other
    • None
    • Platform: Sun, OS: Solaris

    Description

      I'm running Hudson 1.225 and I run into this error after a couple of builds.

      started
      [workspace] $ cleartool rmview -force hudson_base_1_2_Nightly
      FATAL: java.io.IOException: Too many open files

      java.io.IOException: java.io.IOException: Too many open files
      at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
      at java.lang.ProcessImpl.start(ProcessImpl.java:65)
      at java.lang.ProcessBuilder.start(ProcessBuilder.java:451)

      at hudson.Proc$LocalProc.<init>(Proc.java:104)
      at hudson.Proc$LocalProc.<init>(Proc.java:82)
      at hudson.Launcher$LocalLauncher.createLocalProc(Launcher.java:291)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:282)

      at
      hudson.plugins.clearcase.HudsonClearToolLauncher.run(HudsonClearToolLauncher.java:54)
      at hudson.plugins.clearcase.ClearToolSnapshot.rmview(ClearToolSnapshot.java:64)
      at
      hudson.plugins.clearcase.action.UcmSnapshotCheckoutAction.checkout(UcmSnapshotCheckoutAction.java:33)

      at
      hudson.plugins.clearcase.AbstractClearCaseScm.checkout(AbstractClearCaseScm.java:133)
      at
      hudson.plugins.clearcase.AbstractClearCaseScm.checkout(AbstractClearCaseScm.java:113)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:574)

      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:251)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:225)
      at hudson.model.Run.run(Run.java:771)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:202)

      at hudson.model.ResourceController.execute(ResourceController.java:70)
      at hudson.model.Executor.run(Executor.java:82)

      Not sure if it is a plugin (ClearCase) or Hudson core issue. This occurs both
      with 0.5 and 0.6 of the ClearCase plugin.

      Attachments

        Issue Links

          Activity

            Code changed in hudson
            User: : redsolo
            Path:
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearCaseChangeLogSet.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/DefaultPollAction.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/base/BaseChangeLogAction.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/base/BaseSaveChangeLogAction.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmChangeLogAction.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmChangeLogParser.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmSaveChangeLogAction.java
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolExecTest.java
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/DefaultPollActionTest.java
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/base/BaseChangeLogActionTest.java
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ucm/UcmChangeLogActionTest.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10348
            Log:
            JENKINS-1921 Closes all readers/streams

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : redsolo Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearCaseChangeLogSet.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/DefaultPollAction.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/base/BaseChangeLogAction.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/base/BaseSaveChangeLogAction.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmChangeLogAction.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmChangeLogParser.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmSaveChangeLogAction.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolExecTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/DefaultPollActionTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/base/BaseChangeLogActionTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ucm/UcmChangeLogActionTest.java http://fisheye4.cenqua.com/changelog/hudson/?cs=10348 Log: JENKINS-1921 Closes all readers/streams
            redsolo redsolo added a comment -

            Went through code and made sure all streams and Reader objects were properly closed.

            redsolo redsolo added a comment - Went through code and made sure all streams and Reader objects were properly closed.

            Code changed in hudson
            User: : sunfire
            Path:
            branches/clearcase-0.7-SNAPSHOT/nbactions.xml
            branches/clearcase-0.7-SNAPSHOT/src/main/java/hudson/plugins/clearcase/PluginImpl.java
            branches/clearcase-0.7-SNAPSHOT/src/main/java/hudson/plugins/clearcase/ucm/UcmMakeBaseline.java
            branches/clearcase-0.7-SNAPSHOT/src/main/resources/hudson/plugins/clearcase/ucm/UcmMakeBaseline/config.jelly
            branches/clearcase-0.7-SNAPSHOT/src/main/webapp/ucm/mkbl/comment.html
            branches/clearcase-0.7-SNAPSHOT/src/main/webapp/ucm/mkbl/lock.html
            branches/clearcase-0.7-SNAPSHOT/src/main/webapp/ucm/mkbl/name.html
            http://fisheye4.cenqua.com/changelog/hudson/?cs=10526
            Log:
            JENKINS-1921

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sunfire Path: branches/clearcase-0.7-SNAPSHOT/nbactions.xml branches/clearcase-0.7-SNAPSHOT/src/main/java/hudson/plugins/clearcase/PluginImpl.java branches/clearcase-0.7-SNAPSHOT/src/main/java/hudson/plugins/clearcase/ucm/UcmMakeBaseline.java branches/clearcase-0.7-SNAPSHOT/src/main/resources/hudson/plugins/clearcase/ucm/UcmMakeBaseline/config.jelly branches/clearcase-0.7-SNAPSHOT/src/main/webapp/ucm/mkbl/comment.html branches/clearcase-0.7-SNAPSHOT/src/main/webapp/ucm/mkbl/lock.html branches/clearcase-0.7-SNAPSHOT/src/main/webapp/ucm/mkbl/name.html http://fisheye4.cenqua.com/changelog/hudson/?cs=10526 Log: JENKINS-1921
            redsolo redsolo added a comment -

            Re-opened to use the Mockito mocking framework to test that all streams/readers are closed
            as they should.

            redsolo redsolo added a comment - Re-opened to use the Mockito mocking framework to test that all streams/readers are closed as they should.
            jcrouvi jcrouvi added a comment -

            Hi,

            We experience the same problem with CVS.
            Configuration:
            java version "1.6.0_06"
            Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
            Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode)

            Hudson ver. 1.262
            CVS 1.11.22 (client/server)
            redhat-linux, 2.6.18-92.1.1.el5

            The log contains the following message:
            started
            [workspace] $ cvs -q -z3 update -PdC -D "Tuesday, December 2, 2008 7:34:19 AM UTC"
            FATAL: Cannot run program "cvs" (in directory
            "/ige/hudson/work/jobs/example-utest/workspace"): java.io.IOException: error=24,
            Too many open files
            java.io.IOException: Cannot run program "cvs" (in directory
            "/ige/hudson/work/jobs/example-utest/workspace"): java.io.IOException: error=24,
            Too many open files
            at java.lang.ProcessBuilder.start(ProcessBuilder.java:459)
            at hudson.Proc$LocalProc.<init>(Proc.java:104)
            at hudson.Proc$LocalProc.<init>(Proc.java:82)
            at hudson.Launcher$LocalLauncher.createLocalProc(Launcher.java:311)
            at hudson.Launcher$LocalLauncher.launch(Launcher.java:302)
            at hudson.Launcher.launch(Launcher.java:140)
            at hudson.Launcher.launch(Launcher.java:92)
            at hudson.scm.CVSSCM.run(CVSSCM.java:856)
            at hudson.scm.CVSSCM.update(CVSSCM.java:428)
            at hudson.scm.CVSSCM.checkout(CVSSCM.java:251)
            at hudson.model.AbstractProject.checkout(AbstractProject.java:666)
            at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:261)
            at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:235)
            at hudson.model.Run.run(Run.java:817)
            at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:204)
            at hudson.model.ResourceController.execute(ResourceController.java:70)
            at hudson.model.Executor.run(Executor.java:90)
            Caused by: java.io.IOException: java.io.IOException: error=24, Too many open files
            at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
            at java.lang.ProcessImpl.start(ProcessImpl.java:65)
            at java.lang.ProcessBuilder.start(ProcessBuilder.java:452)
            ... 16 more

            jcrouvi jcrouvi added a comment - Hi, We experience the same problem with CVS. Configuration: java version "1.6.0_06" Java(TM) SE Runtime Environment (build 1.6.0_06-b02) Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode) Hudson ver. 1.262 CVS 1.11.22 (client/server) redhat-linux, 2.6.18-92.1.1.el5 The log contains the following message: started [workspace] $ cvs -q -z3 update -PdC -D "Tuesday, December 2, 2008 7:34:19 AM UTC" FATAL: Cannot run program "cvs" (in directory "/ige/hudson/work/jobs/example-utest/workspace"): java.io.IOException: error=24, Too many open files java.io.IOException: Cannot run program "cvs" (in directory "/ige/hudson/work/jobs/example-utest/workspace"): java.io.IOException: error=24, Too many open files at java.lang.ProcessBuilder.start(ProcessBuilder.java:459) at hudson.Proc$LocalProc.<init>(Proc.java:104) at hudson.Proc$LocalProc.<init>(Proc.java:82) at hudson.Launcher$LocalLauncher.createLocalProc(Launcher.java:311) at hudson.Launcher$LocalLauncher.launch(Launcher.java:302) at hudson.Launcher.launch(Launcher.java:140) at hudson.Launcher.launch(Launcher.java:92) at hudson.scm.CVSSCM.run(CVSSCM.java:856) at hudson.scm.CVSSCM.update(CVSSCM.java:428) at hudson.scm.CVSSCM.checkout(CVSSCM.java:251) at hudson.model.AbstractProject.checkout(AbstractProject.java:666) at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:261) at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:235) at hudson.model.Run.run(Run.java:817) at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:204) at hudson.model.ResourceController.execute(ResourceController.java:70) at hudson.model.Executor.run(Executor.java:90) Caused by: java.io.IOException: java.io.IOException: error=24, Too many open files at java.lang.UNIXProcess.<init>(UNIXProcess.java:148) at java.lang.ProcessImpl.start(ProcessImpl.java:65) at java.lang.ProcessBuilder.start(ProcessBuilder.java:452) ... 16 more
            sunfire sunfire added a comment -

            Since this seems to affect more than just Clearcase plugin I'm putting this
            issue on the Hudson core.
            Erik fixes a few "errors" with streams in the Clearcase plugins, obviously there
            are some of these in the core as well.

            sunfire sunfire added a comment - Since this seems to affect more than just Clearcase plugin I'm putting this issue on the Hudson core. Erik fixes a few "errors" with streams in the Clearcase plugins, obviously there are some of these in the core as well.

            Merging with the existing issue.

                • This issue has been marked as a duplicate of 715 ***
            kohsuke Kohsuke Kawaguchi added a comment - Merging with the existing issue. This issue has been marked as a duplicate of 715 ***

            People

              kohsuke Kohsuke Kawaguchi
              sunfire sunfire
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: