Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-19345

NoClassDefFoundError on project build

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • core, git-plugin
    • None
    • OS: Debian 7

    Description

      I have several free style projects, some of then run on a scheduled basis and some of them using a post commit hook from Github.
      After upgrading to version 1.528 and updating the installed plugins, the automatic some manual builds and all automatic builds started failing, apart from that, another exception it's raised when trying to open the changelog for a build. Here are the exceptions:

      1) On the builds that fail here is the exception log:
      tarted by user Federico Saravia
      Building in workspace /var/lib/jenkins/jobs/test-api/workspace
      Checkout:workspace / /var/lib/jenkins/jobs/test-api/workspace - hudson.remoting.LocalChannel@6281d31b
      Using strategy: Default
      Last Built Revision: Revision e87ed66aeab0ed5b9da96c574c3c326e4a70e332 (origin/development)
      Fetching changes from 1 remote Git repository
      Fetching upstream changes from origin
      Commencing build of Revision 81206b9ccedc3eeaa1890dc4e960359ad989202d (origin/development)
      Checking out Revision 81206b9ccedc3eeaa1890dc4e960359ad989202d (origin/development)
      FATAL: hudson/tasks/Mailer$UserProperty
      java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
      at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:70)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:59)
      at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:23)
      at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:922)
      at hudson.model.AbstractBuild.access$600(AbstractBuild.java:105)
      at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:681)
      at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:88)
      at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:581)
      at hudson.model.Run.execute(Run.java:1603)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:247)
      Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
      at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1315)
      at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:1068)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
      ... 12 more

      On the changelog screen the raised Exception is different (only if there has been changes in the build), the exception is attached.

      Another thing, maybe related to the issue is that jenkins tells me that I have old or unreadable data:
      hudson.model.FreeStyleProject api NoClassDefFoundError: hudson/tasks/Mailer$UserProperty

      I can delete that data, but every time one of the builds fail it comes back.
      I may point that I never installed or used the Mailer plugin. The only plugins I installed and use are the Git plugin and the SSH plugin, so I don't know where this Mailer$UserProperty came from.

      I already tried downgrading the plugins to their bundled version but that didn's solve the problem

      Attachments

        Issue Links

          Activity

            grahamrhay Graham Hay added a comment -

            I'm seeing the same problem having just upgraded to Jenkins 1.557. I have version 2.1.0 of the Git plugin, and version 1.8 of the Mailer plugin. Is there a workaround, or versions of the plugins that are known to work together?

            grahamrhay Graham Hay added a comment - I'm seeing the same problem having just upgraded to Jenkins 1.557. I have version 2.1.0 of the Git plugin, and version 1.8 of the Mailer plugin. Is there a workaround, or versions of the plugins that are known to work together?
            grahamrhay Graham Hay added a comment -

            I uninstalled and re-installed the Git plugin (suggested elsewhere), which seems to have "fixed" it.

            grahamrhay Graham Hay added a comment - I uninstalled and re-installed the Git plugin (suggested elsewhere), which seems to have "fixed" it.

            @Graham Hay I tried what you suggested but I still get the same error every time the GIT plugin updates from the origin repo.

            tanis Valerio Santinelli added a comment - @Graham Hay I tried what you suggested but I still get the same error every time the GIT plugin updates from the origin repo.
            grahamrhay Graham Hay added a comment -

            Yeah, I still had problems after that too. I've since updated to Jenkins 1.558, and v2.2.0 of the Git plugin; and not seen that error recently. I had a look in the commit log for the plugin, but couldn't see anything that was an obvious fix.

            grahamrhay Graham Hay added a comment - Yeah, I still had problems after that too. I've since updated to Jenkins 1.558, and v2.2.0 of the Git plugin; and not seen that error recently. I had a look in the commit log for the plugin, but couldn't see anything that was an obvious fix.

            I solve this problem downgrading the git-client and git plugins to 1.9.0 and 1.5.0 respectively, as Berg Systeme suggested in his blog:
            http://blog.berg-systeme.de/2014/05/15/downgrade-jenkins-git-plugin/

            panuquets Rafa Torregrosa added a comment - I solve this problem downgrading the git-client and git plugins to 1.9.0 and 1.5.0 respectively, as Berg Systeme suggested in his blog: http://blog.berg-systeme.de/2014/05/15/downgrade-jenkins-git-plugin/

            People

              ndeloof Nicolas De Loof
              fedesaravia Federico Saravia
              Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: