Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20138

swarm 1.9 can't connect to current LTS as slave.jar too old

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Fixed
    • swarm-plugin
    • Master: CentOS 6
      Slaves: CentOS 6
      Java: OpenJDK 1.7.0_25

    Description

      Using the 1.9 version of the swarm plugin to connect to LTS 1.509.4 fails because the embedded slave.jar (version 2.12) is too old
      Current slave.jar version in LTS 1.509.4 is 2.32

      The initial connection works but the slave soon disconnects with 'slave too old' displayed in the GUI.

      Attachments

        Activity

          Code changed in jenkins
          User: ssogabe
          Path:
          client/pom.xml
          http://jenkins-ci.org/commit/swarm-plugin/9512c20a9c2c861ae041531aea084159ebe49569
          Log:
          [FIXED JENKINS-20138] Updated slave.jar

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: ssogabe Path: client/pom.xml http://jenkins-ci.org/commit/swarm-plugin/9512c20a9c2c861ae041531aea084159ebe49569 Log: [FIXED JENKINS-20138] Updated slave.jar

          Thank you ssogabe - that was really fast!

          Do you know when a new version of the swarm plugin be available?

          Thanks again

          bdellegrazie Brett Delle Grazie added a comment - Thank you ssogabe - that was really fast! Do you know when a new version of the swarm plugin be available? Thanks again
          sogabe sogabe added a comment -

          I've just released swarm plugin 1.10. Wait for a few moments for the plugin to come up on Update Center.

          sogabe sogabe added a comment - I've just released swarm plugin 1.10. Wait for a few moments for the plugin to come up on Update Center.

          @sogabe, It hasn't appeared yet but I presume this is because we're on LTS.
          Thanks again for the fast response.

          bdellegrazie Brett Delle Grazie added a comment - @sogabe, It hasn't appeared yet but I presume this is because we're on LTS. Thanks again for the fast response.
          markewaite Mark Waite added a comment -

          I confirmed that swarm client 1.11 connects to LTS 1.532.1 and am closing this issue.

          markewaite Mark Waite added a comment - I confirmed that swarm client 1.11 connects to LTS 1.532.1 and am closing this issue.

          Code changed in jenkins
          User: Martin Konrad
          Path:
          manifests/params.pp
          http://jenkins-ci.org/commit/puppet-jenkins/2963468b2364c1d8216d952a7c9da4831d40c133
          Log:
          Install swarm-client 1.16

          This is necessary to avoid compatibility issues with newer Jenkins
          versions (e.g. see https://issues.jenkins-ci.org/browse/JENKINS-20138).

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Martin Konrad Path: manifests/params.pp http://jenkins-ci.org/commit/puppet-jenkins/2963468b2364c1d8216d952a7c9da4831d40c133 Log: Install swarm-client 1.16 This is necessary to avoid compatibility issues with newer Jenkins versions (e.g. see https://issues.jenkins-ci.org/browse/JENKINS-20138 ).

          People

            sogabe sogabe
            bdellegrazie Brett Delle Grazie
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: