Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20331

Test connection issue: client is version 4.0.4, and the server is version 4.0.3

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Not A Defect
    • teamconcert-plugin
    • None
    • RTC 4.0.3 RH Linux x86_64 2.6.2

    Description

      On my buildserver, I have only RTC 4.0.3 installed yet the plugin will not connect, giving me:

      Your client is version 4.0.4, and the server is version 4.0.3. These versions are not compatible.

      I had this working a work or so ago but had to rebuild my server so I suspect (but don't know for sure) that this issue came about because of the 10/23/13 build.

      Attachments

        Activity

          o386600 Andy Jewell added a comment -

          FYI - I just installed 1.0.11 of the plugin and no longer have the problem.

          o386600 Andy Jewell added a comment - FYI - I just installed 1.0.11 of the plugin and no longer have the problem.

          This issue is a mis-configuration issue. The new version of the plugin will not of fixed it, I suspect something else was changed.

          The problem is due to using a 4.0.4 build toolkit against a 4.0.3 server. A 4.0.3 or earlier build toolkit needs to be used to work with a 4.0.3 server.

          The server supports N-1 clients where N is the major version of the server (in this case N is 4).

          hfraserdube Heather Fraser-Dube added a comment - This issue is a mis-configuration issue. The new version of the plugin will not of fixed it, I suspect something else was changed. The problem is due to using a 4.0.4 build toolkit against a 4.0.3 server. A 4.0.3 or earlier build toolkit needs to be used to work with a 4.0.3 server. The server supports N-1 clients where N is the major version of the server (in this case N is 4).

          Hmm I haven't explained that well, N is 4.0.3 but 4.0.3 - 1 is 3.*

          In essence the server doesn't support clients newer than itself.

          hfraserdube Heather Fraser-Dube added a comment - Hmm I haven't explained that well, N is 4.0.3 but 4.0.3 - 1 is 3.* In essence the server doesn't support clients newer than itself.

          Not a defect in the plugin, its a configuration issue with the job.

          hfraserdube Heather Fraser-Dube added a comment - Not a defect in the plugin, its a configuration issue with the job.

          People

            Unassigned Unassigned
            o386600 Andy Jewell
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: