Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-20367

If a failed test result the plugin causes a Failed build

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Fixed
    • mstestrunner-plugin
    • None
    • Windows 7 Pro, Jenkins 1.509.4, MStestRunner 1.0.1

    Description

      When running the plugin and the plugin runs, so tests actually get executed, and a test fails it causes the build to fail. This is before it even gets to parsing the results so it is caused by this plugin.
      This is critical because the failure prevents all other tasks from running that are after that.

      You probably want to add something like the MSBuild task has where you can Continue on Failures or mark as Unstable on Failures.

      Attachments

        Activity

          ido_ran Ido Ran added a comment -

          Fixed in version 1.1.0.
          I've add a checkbox for Continue On Failed Test which is off by default but when turned on the plugin will report success even when test have failed.

          ido_ran Ido Ran added a comment - Fixed in version 1.1.0. I've add a checkbox for Continue On Failed Test which is off by default but when turned on the plugin will report success even when test have failed.

          People

            ido_ran Ido Ran
            jstarbird Jon Starbird
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: