Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-21865

LDAP plugin classes missing on LTS 1.532.2

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Blocker
    • Resolution: Cannot Reproduce
    • ldap-plugin
    • None
    • CentOS - 2.6.18-238.19.1.el5

    Description

      After upgrading to LTS 1.532.2, I can't authenticate with LDAP.
      It turned out the whole ldap plugins classes missing.
      Copying the the ldap classes from the previous version to:
      <JENKINS_HOME>/plugins/ldap/WEB-INF/classes solved the issue.

      Attachments

        Activity

          amargono amargono added a comment -

          Hello,

          Any update or comment on this issue?

          Regards

          amargono amargono added a comment - Hello, Any update or comment on this issue? Regards
          mishael Mishael Kim added a comment -

          I just upgraded to LTS 1.532.2 using my old backed up versions of my plugins and I didn't have any issues. It worked initially with LDAP plugin version 1.4 and it also seemed to work just fine when upgrading to version 1.8. Cannot reproduce bug.

          mishael Mishael Kim added a comment - I just upgraded to LTS 1.532.2 using my old backed up versions of my plugins and I didn't have any issues. It worked initially with LDAP plugin version 1.4 and it also seemed to work just fine when upgrading to version 1.8. Cannot reproduce bug.
          amargono amargono added a comment -

          Our LDAP configuration requires modification on
          <$WEBHOME>/plugins/ldap/WEB-INF/classes/LDAPBindSecurityRealm.groovy which missing after the upgrade.
          Else the LDAP authentication will fail.

          amargono amargono added a comment - Our LDAP configuration requires modification on <$WEBHOME>/plugins/ldap/WEB-INF/classes/LDAPBindSecurityRealm.groovy which missing after the upgrade. Else the LDAP authentication will fail.
          amargono amargono added a comment -
              • Update ***
                I found out that the LDAP plugin classes was packaged in a jar file.
                It is located at <$WEBHOME>/plugins/ldap/WEB-INF/lib/classes.jar
                I managed to extract, modify the LDAPBindSecurityRealm.groovy, put it back to the classes.jar.
                Restarted Jenkins and the LDAP authentication worked.

          Regards,
          amargono

          amargono amargono added a comment - Update *** I found out that the LDAP plugin classes was packaged in a jar file. It is located at <$WEBHOME>/plugins/ldap/WEB-INF/lib/classes.jar I managed to extract, modify the LDAPBindSecurityRealm.groovy, put it back to the classes.jar. Restarted Jenkins and the LDAP authentication worked. Regards, amargono
          danielbeck Daniel Beck added a comment -

          User requires patched plugin, which seems to have been overridden during update.

          As the issue is resolved by patching the new plugin files again, and too little information was provided to reproduce the issue (what versions of Jenkins and LDAP plugin were updated from, was the plugin pinned, what's the nature of the change in the script file ...), I'm marking this as resolved/cannot reproduce.

          Feel free to provide that information and reopen (but I honestly think nobody'll work on it since it's it's a very narrow use case that seems to be affected by this – also, newer LDAP plugin versions have more config options, so you might not need to patch that file anymore).

          danielbeck Daniel Beck added a comment - User requires patched plugin, which seems to have been overridden during update. As the issue is resolved by patching the new plugin files again, and too little information was provided to reproduce the issue (what versions of Jenkins and LDAP plugin were updated from, was the plugin pinned, what's the nature of the change in the script file ...), I'm marking this as resolved/cannot reproduce. Feel free to provide that information and reopen (but I honestly think nobody'll work on it since it's it's a very narrow use case that seems to be affected by this – also, newer LDAP plugin versions have more config options, so you might not need to patch that file anymore).

          People

            Unassigned Unassigned
            amargono amargono
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: