Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22115

FATAL: hudson/tasks/Mailer$UserProperty

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Critical
    • Resolution: Duplicate
    • mailer-plugin
    • None
    • Jenkins 1.554

    Description

      Occasionally getting the following failure at the end of every one of my builds:

      FATAL: hudson/tasks/Mailer$UserProperty
      java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
      	at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:80)
      	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:74)
      	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:51)
      	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
      	at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:922)
      	at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:896)
      	at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:413)
      	at hudson.model.AbstractBuild.getCulprits(AbstractBuild.java:410)
      	at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:729)
      	at hudson.model.Run.execute(Run.java:1701)
      	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      	at hudson.model.ResourceController.execute(ResourceController.java:88)
      	at hudson.model.Executor.run(Executor.java:231)
      Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
      	at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1365)
      	at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1315)
      	at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:1068)
      	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      	... 13 more
      

      For reference:

      Plugins
      
      Name  ↓
      Version   
      Enabled   
      Pinned   
      analysis-core	1.55	true	false
      ant	1.2	true	false
      antisamy-markup-formatter	1.0	true	false
      build-environment	1.4	true	false
      chef	0.0.6	true	false
      cocoapods-integration	0.2.0	true	false
      credentials	1.10	true	true
      cvs	2.11	true	true
      envinject	1.89	true	false
      external-monitor-job	1.2	true	true
      ghprb	1.9	true	false
      git	2.0.4	true	false
      git-client	1.6.4	true	false
      github	1.8	true	false
      github-api	1.44	true	false
      github-oauth	0.14	true	false
      graphiteIntegrator	1.2-SNAPSHOT (private-03/06/2014 15:48-gba)	true	false
      greenballs	1.14	true	false
      hipchat	0.1.4	true	false
      hockeyapp	1.0.5	true	false
      ios-device-connector	1.2	true	false
      javadoc	1.1	true	false
      ldap	1.8	true	true
      mailer	1.8	true	true
      matrix-auth	1.1	true	false
      maven-plugin	2.1	true	true
      multiple-scms	0.3	true	false
      nodejs	0.2.1	true	false
      nvm	0.2.1	true	false
      pam-auth	1.1	true	true
      pmd	3.38	true	false
      postbuild-task	1.8	true	false
      project-description-setter	1.1	true	false
      publish-over-ssh	1.11	true	false
      pyenv	0.0.6	true	false
      python	1.2	true	false
      rbenv	0.0.16git	true	false
      ruby-runtime	0.12	true	false
      scm-api	0.2	true	false
      shiningpanda	0.20	true	false
      sloccount	1.15	true	false
      ssh	2.4	true	false
      ssh-agent	1.4.1	true	false
      ssh-credentials	1.6.1	true	true
      ssh-slaves	1.6	true	true
      started-by-envvar	1.0	true	false
      subversion	2.2	true	true
      tasks	4.39	true	false
      token-macro	1.10	true	false
      translation	1.11	true	true
      versionnumber	1.4.1	true	false
      windows-slaves	1.0	false	false
      ws-cleanup	0.20	true	false
      xcode-plugin	1.4.2	true	false
      xunit	1.84	true	false
      

      Attachments

        Issue Links

          Activity

            We are seeing the same problem, again with Jenkins 1.544, git-plugin 2.0.4, mailer-plugin 1.8 and all plugins up-to-date. This causes builds to fail even after the successful build message has been mailed out.

            cartwright Sarah Cartwright added a comment - We are seeing the same problem, again with Jenkins 1.544, git-plugin 2.0.4, mailer-plugin 1.8 and all plugins up-to-date. This causes builds to fail even after the successful build message has been mailed out.

            We are experiencing the same issue with 1.557 and all plugins up to date.

            tanis Valerio Santinelli added a comment - We are experiencing the same issue with 1.557 and all plugins up to date.
            pkraeutli Philipp Kräutli added a comment - - edited

            We have the same problem with 1.558, all plugins up to date.

            SEVERE: Failed to record SCM polling
            java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
            	at hudson.plugins.git.GitSCM.isRevExcluded(GitSCM.java:1378)
            	at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:539)
            	at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:457)
            	at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356)
            	at hudson.scm.SCM.poll(SCM.java:373)
            	at hudson.model.AbstractProject.pollWithWorkspace(AbstractProject.java:1511)
            	at hudson.model.AbstractProject._poll(AbstractProject.java:1481)
            	at hudson.model.AbstractProject.poll(AbstractProject.java:1399)
            	at com.cloudbees.jenkins.GitHubPushTrigger$1.runPolling(GitHubPushTrigger.java:73)
            	at com.cloudbees.jenkins.GitHubPushTrigger$1.run(GitHubPushTrigger.java:98)
            	at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
            	at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28)
            	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
            	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
            	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
            	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            	at java.lang.Thread.run(Thread.java:662)
            Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
            	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
            	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
            	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
            	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
            	... 18 more
            

            Or:

            Apr 7, 2014 4:00:37 PM hudson.ExpressionFactory2$JexlExpression evaluate
            WARNING: Caught exception evaluating: it.changeSet in /job/XYZ/927/. Reason: java.lang.reflect.InvocationTargetException
            java.lang.reflect.InvocationTargetException
            	at sun.reflect.GeneratedMethodAccessor402.invoke(Unknown Source)
            	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            	at java.lang.reflect.Method.invoke(Method.java:597)
            	at org.apache.commons.jexl.util.PropertyExecutor.execute(PropertyExecutor.java:125)
            	at org.apache.commons.jexl.util.introspection.UberspectImpl$VelGetterImpl.invoke(UberspectImpl.java:314)
            	at ...
            	at java.lang.Thread.run(Thread.java:662)
            Caused by: java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty
            	at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:80)
            	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:64)
            	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:51)
            	at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29)
            	at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:862)
            	at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:836)
            	... 115 more
            Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty
            	at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375)
            	at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325)
            	at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078)
            	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
            	... 121 more
            
            pkraeutli Philipp Kräutli added a comment - - edited We have the same problem with 1.558, all plugins up to date. SEVERE: Failed to record SCM polling java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty at hudson.plugins.git.GitSCM.isRevExcluded(GitSCM.java:1378) at hudson.plugins.git.GitSCM.compareRemoteRevisionWithImpl(GitSCM.java:539) at hudson.plugins.git.GitSCM.compareRemoteRevisionWith(GitSCM.java:457) at hudson.scm.SCM._compareRemoteRevisionWith(SCM.java:356) at hudson.scm.SCM.poll(SCM.java:373) at hudson.model.AbstractProject.pollWithWorkspace(AbstractProject.java:1511) at hudson.model.AbstractProject._poll(AbstractProject.java:1481) at hudson.model.AbstractProject.poll(AbstractProject.java:1399) at com.cloudbees.jenkins.GitHubPushTrigger$1.runPolling(GitHubPushTrigger.java:73) at com.cloudbees.jenkins.GitHubPushTrigger$1.run(GitHubPushTrigger.java:98) at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118) at jenkins.util.ContextResettingExecutorService$1.run(ContextResettingExecutorService.java:28) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang. Thread .run( Thread .java:662) Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375) at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325) at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078) at java.lang. ClassLoader .loadClass( ClassLoader .java:247) ... 18 more Or: Apr 7, 2014 4:00:37 PM hudson.ExpressionFactory2$JexlExpression evaluate WARNING: Caught exception evaluating: it.changeSet in /job/XYZ/927/. Reason: java.lang.reflect.InvocationTargetException java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor402.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.apache.commons.jexl.util.PropertyExecutor.execute(PropertyExecutor.java:125) at org.apache.commons.jexl.util.introspection.UberspectImpl$VelGetterImpl.invoke(UberspectImpl.java:314) at ... at java.lang. Thread .run( Thread .java:662) Caused by: java.lang.NoClassDefFoundError: hudson/tasks/Mailer$UserProperty at hudson.plugins.git.GitChangeLogParser.parseCommit(GitChangeLogParser.java:80) at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:64) at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:51) at hudson.plugins.git.GitChangeLogParser.parse(GitChangeLogParser.java:29) at hudson.model.AbstractBuild.calcChangeSet(AbstractBuild.java:862) at hudson.model.AbstractBuild.getChangeSet(AbstractBuild.java:836) ... 115 more Caused by: java.lang.ClassNotFoundException: hudson.tasks.Mailer$UserProperty at jenkins.util.AntClassLoader.findClassInComponents(AntClassLoader.java:1375) at jenkins.util.AntClassLoader.findClass(AntClassLoader.java:1325) at jenkins.util.AntClassLoader.loadClass(AntClassLoader.java:1078) at java.lang. ClassLoader .loadClass( ClassLoader .java:247) ... 121 more
            pkraeutli Philipp Kräutli added a comment - I found this suggestion by Graham Hay here https://issues.jenkins-ci.org/browse/JENKINS-19345?focusedCommentId=198210&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-198210 and it seems to have solved the issue for me.
            oleg_nenashev Oleg Nenashev added a comment -

            Closing as a duplicate of JENKINS-19345.
            I suppose there's no actions to be done on the Mailer plugin's side

            oleg_nenashev Oleg Nenashev added a comment - Closing as a duplicate of JENKINS-19345 . I suppose there's no actions to be done on the Mailer plugin's side

            People

              Unassigned Unassigned
              ampledata Greg Albrecht
              Votes:
              4 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: