Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-22730

Swarm Plugin seems to use old slave.jar for Jenkins 1.549

    XMLWordPrintable

Details

    Description

      Swarm plugin 1.15 seems to have slave.jar version 2.32. My Jenkins stands at 1.549 which requires slave.jar version 2.33. As a result, I can't connect the swarm slave to the master. I get the error "Node marked offline because it uses old version of slave.jar"

      Attachments

        Activity

          aflat aflat added a comment -

          This also effects the LTS version of jenkins.

          aflat aflat added a comment - This also effects the LTS version of jenkins.
          mindjiver Peter Jönsson added a comment - I submitted a PR for this here: https://github.com/jenkinsci/swarm-plugin/pull/14

          Code changed in jenkins
          User: Peter Jönsson
          Path:
          client/pom.xml
          http://jenkins-ci.org/commit/swarm-plugin/a6f7f6f4c1fc165bbc5bb6ac364bfb8549e9124a
          Log:
          [FIXED JENKINS-22730] Bump remoting to match Jenkins LTS

          Swarm nodes are offlined by Jenkins with the following message:

          "This node is offline because it uses old slave.jar"

          Therefore we bump the version of the remoting library to match the one
          used in Jenkins LTS (1.544.1).

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Peter Jönsson Path: client/pom.xml http://jenkins-ci.org/commit/swarm-plugin/a6f7f6f4c1fc165bbc5bb6ac364bfb8549e9124a Log: [FIXED JENKINS-22730] Bump remoting to match Jenkins LTS Swarm nodes are offlined by Jenkins with the following message: "This node is offline because it uses old slave.jar" Therefore we bump the version of the remoting library to match the one used in Jenkins LTS (1.544.1).

          Code changed in jenkins
          User: Peter Jönsson
          Path:
          client/pom.xml
          http://jenkins-ci.org/commit/swarm-plugin/fd44a05c89500a7b39240d07d6d96910a57b91fa
          Log:
          Merge pull request #14 from mindjiver/JENKINS-22730-swarm-plugin-seems-to-use-old-slave.jar-for-Jenkins

          [FIXED JENKINS-22730] Bump remoting to match Jenkins LTS

          Compare: https://github.com/jenkinsci/swarm-plugin/compare/d5b2b87e38c1...fd44a05c8950

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Peter Jönsson Path: client/pom.xml http://jenkins-ci.org/commit/swarm-plugin/fd44a05c89500a7b39240d07d6d96910a57b91fa Log: Merge pull request #14 from mindjiver/ JENKINS-22730 -swarm-plugin-seems-to-use-old-slave.jar-for-Jenkins [FIXED JENKINS-22730] Bump remoting to match Jenkins LTS Compare: https://github.com/jenkinsci/swarm-plugin/compare/d5b2b87e38c1...fd44a05c8950

          Version 1.16 released with this fix.

          mindjiver Peter Jönsson added a comment - Version 1.16 released with this fix.

          People

            mindjiver Peter Jönsson
            venkat_nagappan Venkat Nagappan
            Votes:
            3 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: