Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-23333

Label display wrong when using operators in expression

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Component/s: core
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.532.2 LTS
    • Similar Issues:

      Description

      Behaviour:

      1. go to job configuration
      2. enable "Restrict where this project can be run"
      3. enter expression with operator, e.g. "label1&&label2"
      4. go to slave that is configured to run label1 and label2
      5. klick on label1 (link next to "Labels:")
      6. URL $your_jenkins/label/label1/? will open
      7. Project using "label1&&label2" won't be displayed, only projects that use "label1" and nothing else will be displayed

      Workaround: enter $your_jenkins/label/label1&&label2/ as URL


      Expected behaviour:

      Klicking on a label (i.e. navigating to $your_jenkins/label/label1/?) should display all jobs that actually make use of this label regardless of using it alone or in combination with other labels (via an operator).

        Attachments

        1. LJPa_jdk7.png
          LJPa_jdk7.png
          174 kB
        2. LJPa_macos.png
          LJPa_macos.png
          143 kB
        3. LJPa_unassigned.png
          LJPa_unassigned.png
          83 kB
        4. LJPb_jdk7.png
          LJPb_jdk7.png
          181 kB
        5. LJPb_macos.png
          LJPb_macos.png
          128 kB

          Activity

          dominiquebrice Dominique Brice added a comment - - edited

          Initial release 1.0.1 of the plugin published, already available in the repo:
          http://repo.jenkins-ci.org/releases/org/jenkins-ci/plugins/label-linked-jobs/1.0.1/

          Should appear soon in Jenkins plugin management section.

          Edit: wiki page is done.

          Steffen, let us know how it goes for you!

          danielbeck Daniel Beck added a comment -

          I think this issue can be resolved, WDYT Steffen?


          Dominique Brice:

          new "Labels Dashboard" to have a global view of all labels defined and used in jobs & nodes

          Looks like I can finally kill off my own (mostly abandoned) attempts at writing better labels UI. I'm really looking forward to what you're going to add to the plugin next!

          dominiquebrice Dominique Brice added a comment -

          Daniel, let's continue the discussion about the plugin on this page.
          Steffen, I can now see the plugin (v1.0.1) proposed in the plugin management section. Does the install worked well for you?

          sbreitbach Steffen Breitbach added a comment -

          I'm super busy at the moment. I managed to install it but didn't have the time yet to restart Jenkins and have a closer look. Sorry.

          I'll look at this as soon as possible.

          dominiquebrice Dominique Brice added a comment -

          I set it to "done" (via a plugin) rather than "fixed" (behavior in Jenkins core remains the same).


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sbreitbach Steffen Breitbach
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: