Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27343

Plugin does not compile with core > 1.554 (case 12803)

    XMLWordPrintable

Details

    Description

      Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5:compile (default-compile) on project pretested-integration: Compilation failure: Compilation failure:
      [ERROR] /home/bue/gitlab-repos/github/pretested-integration-plugin/src/main/java/org/jenkinsci/plugins/pretestedintegration/IntegrationStrategy.java:[29,11] error: @DataBoundConstructor may not be used on an abstract class (only on concrete subclasses)
      [ERROR] /home/bue/gitlab-repos/github/pretested-integration-plugin/src/main/java/org/jenkinsci/plugins/pretestedintegration/AbstractSCMBridge.java:[37,11] error: @DataBoundConstructor may not be used on an abstract class (only on concrete subclasses)

      Attachments

        Activity

          There are no comments yet on this issue.

          People

            praqma Praqma Support
            madsnielsen Mads Nielsen
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: