Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27584

NullPointerException in ManualStep.getManualStepLatest

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • None
    • Jenkins version: 1.582
      Plugin version: 0.8.11

    Description

      Attached are the stacktrace for this error.

      Attachments

        Activity

          Do you have any information how to reproduce the issue?

          patbos Patrik Boström added a comment - Do you have any information how to reproduce the issue?

          Found one way to produce NPE, have done a fix on this branch:
          https://github.com/Diabol/delivery-pipeline-plugin/tree/JENKINS-27584_NPE

          Do you have possibility to test it?

          patbos Patrik Boström added a comment - Found one way to produce NPE, have done a fix on this branch: https://github.com/Diabol/delivery-pipeline-plugin/tree/JENKINS-27584_NPE Do you have possibility to test it?

          I have just tested it and it looks like it fixed the problem.

          mmchr Mads Mohr Christensen added a comment - I have just tested it and it looks like it fixed the problem.

          Thank you for testing. The fix is merged into master.

          patbos Patrik Boström added a comment - Thank you for testing. The fix is merged into master.

          Merged to master

          patbos Patrik Boström added a comment - Merged to master

          Released in 0.9.0

          patbos Patrik Boström added a comment - Released in 0.9.0

          People

            patbos Patrik Boström
            mmchr Mads Mohr Christensen
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: