Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-27588

Labels used in Label Factory are shown as not used

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      Labels that are used in a Label Factory (in the nodelabelparameter-plugin) are not caught by the label-linked-jobs-plugin. The plugin falsely reports these labels as not being used by any job, see included images.

      Could the plugin be updated to support this?

        Attachments

          Activity

          Hide
          skalmelid Stefan Kalmelid added a comment -

          Perfect timing, we have Jenkins maintenance planned for this afternoon

          Show
          skalmelid Stefan Kalmelid added a comment - Perfect timing, we have Jenkins maintenance planned for this afternoon
          Hide
          dominiquebrice Dominique Brice added a comment -

          Plugin page updated.
          Stefan Kalmelid, how's the new version working on your prod instance?

          Show
          dominiquebrice Dominique Brice added a comment - Plugin page updated. Stefan Kalmelid , how's the new version working on your prod instance?
          Hide
          skalmelid Stefan Kalmelid added a comment -

          It works well, just one minor issue:

          "There is an important restriction to this feature: for technical and functional reasons, any label containing token or macro (with the ${..} syntax) is ignored."

          Is it possible to ignore tokens or macros using the $SOME_VARIABLE syntax as well?
          I found a few jobs like that, I'll fix them by using the ${SOME_VARIABLE} syntax instead,
          but it will not be obvious to other users how to solve it.

          Show
          skalmelid Stefan Kalmelid added a comment - It works well, just one minor issue: "There is an important restriction to this feature: for technical and functional reasons, any label containing token or macro (with the ${..} syntax) is ignored." Is it possible to ignore tokens or macros using the $SOME_VARIABLE syntax as well? I found a few jobs like that, I'll fix them by using the ${SOME_VARIABLE} syntax instead, but it will not be obvious to other users how to solve it.
          Hide
          dominiquebrice Dominique Brice added a comment - - edited

          Ok, I published a patch version (4.0.2) to correct that. This syntax is not documented on this page so I was not aware of it. I will see if it could be added.

          Show
          dominiquebrice Dominique Brice added a comment - - edited Ok, I published a patch version ( 4.0.2 ) to correct that. This syntax is not documented on this page so I was not aware of it. I will see if it could be added.
          Hide
          skalmelid Stefan Kalmelid added a comment -

          A quick test in our playground environment looks fine, but it will have to wait a few weeks before it becomes live in the production environment.

          Thanks Domi!

          Show
          skalmelid Stefan Kalmelid added a comment - A quick test in our playground environment looks fine, but it will have to wait a few weeks before it becomes live in the production environment. Thanks Domi!

            People

            Assignee:
            dominiquebrice Dominique Brice
            Reporter:
            skalmelid Stefan Kalmelid
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: