Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-28316

Publish Fitnesse results - fails on 1.12 - reverted to 1.8 - works again

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • fitnesse-plugin
    • Windows (master and slave)
      Jenkins version 1.611
      Windows (Server 2008)

    Description

      Upgraded my Jenkins instance (to version 1.611).
      Tried to upgrade fitnesse plugin also from 1.8 to 1.12.

      Results from version 1.2 (works)
      ...
      Reading results as windows-1252 from D:\WS\master\Reports\fitnesse\fitnesse_results.xml
      Parsing results...
      Got results: null (): 1650 right, 0 wrong, 0 ignored, 0 exceptions
      Archiving artifacts
      .....

      Build fails on Version 1.13:
      Reading results as windows-1252 from D:\WS\master\Reports\fitnesse\fitnesse_results.xml
      Parsing results...
      Write fitnesse results to: D:\Apps\Jenkins\jobs\Master Build\builds\7995\
      javax.xml.transform.TransformerException: java.lang.NumberFormatException: For input string: ""
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
      at hudson.plugins.fitnesse.NativePageCountsParser.transformRawResults(NativePageCountsParser.java:26)
      at hudson.plugins.fitnesse.NativePageCountsParser.parse(NativePageCountsParser.java:19)
      at hudson.plugins.fitnesse.FitnesseResultsRecorder.getResults(FitnesseResultsRecorder.java:142)
      at hudson.plugins.fitnesse.FitnesseResultsRecorder.getResults(FitnesseResultsRecorder.java:119)
      at hudson.plugins.fitnesse.FitnesseResultsRecorder.perform(FitnesseResultsRecorder.java:77)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:764)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:724)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
      at hudson.model.Run.execute(Run.java:1769)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:374)
      Caused by: java.lang.NumberFormatException: For input string: ""
      at java.lang.NumberFormatException.forInputString(Unknown Source)
      at java.lang.Integer.parseInt(Unknown Source)
      at java.lang.Integer.parseInt(Unknown Source)
      at hudson.plugins.fitnesse.NativePageCounts.startElement(NativePageCounts.java:68)
      at com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(Unknown Source)
      at com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(Unknown Source)
      at com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown Source)
      at com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown Source)
      at GregorSamsa.template$dot$0()
      at GregorSamsa.applyTemplates()
      at GregorSamsa.applyTemplates()
      at GregorSamsa.transform()
      at com.sun.org.apache.xalan.internal.xsltc.runtime.AbstractTranslet.transform(Unknown Source)
      ... 16 more
      ---------
      java.lang.NumberFormatException: For input string: ""
      at java.lang.NumberFormatException.forInputString(Unknown Source)
      at java.lang.Integer.parseInt(Unknown Source)
      at java.lang.Integer.parseInt(Unknown Source)
      at hudson.plugins.fitnesse.NativePageCounts.startElement(NativePageCounts.java:68)
      at com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.closeStartTag(Unknown Source)
      at com.sun.org.apache.xml.internal.serializer.ToSAXHandler.flushPending(Unknown Source)
      at com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown Source)
      at com.sun.org.apache.xml.internal.serializer.ToXMLSAXHandler.endElement(Unknown Source)
      at GregorSamsa.template$dot$0()
      at GregorSamsa.applyTemplates()
      at GregorSamsa.applyTemplates()
      at GregorSamsa.transform()
      at com.sun.org.apache.xalan.internal.xsltc.runtime.AbstractTranslet.transform(Unknown Source)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
      at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(Unknown Source)
      at hudson.plugins.fitnesse.NativePageCountsParser.transformRawResults(NativePageCountsParser.java:26)
      at hudson.plugins.fitnesse.NativePageCountsParser.parse(NativePageCountsParser.java:19)
      at hudson.plugins.fitnesse.FitnesseResultsRecorder.getResults(FitnesseResultsRecorder.java:142)
      at hudson.plugins.fitnesse.FitnesseResultsRecorder.getResults(FitnesseResultsRecorder.java:119)
      at hudson.plugins.fitnesse.FitnesseResultsRecorder.perform(FitnesseResultsRecorder.java:77)
      at hudson.tasks.BuildStepMonitor$3.perform(BuildStepMonitor.java:45)
      at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:764)
      at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(AbstractBuild.java:724)
      at hudson.model.Build$BuildExecution.post2(Build.java:185)
      at hudson.model.AbstractBuild$AbstractBuildExecution.post(AbstractBuild.java:671)
      at hudson.model.Run.execute(Run.java:1769)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
      at hudson.model.ResourceController.execute(ResourceController.java:98)
      at hudson.model.Executor.run(Executor.java:374)
      Build step 'Publish Fitnesse results report' changed build result to FAILURE
      Build step 'Publish Fitnesse results report' marked build as failure
      Archiving artifacts

      The result set is large.
      I had a similar error in the past with the html publisher plugin and large files (that was fixed at some point in that plugin)

      I had to revert to 1.8 to get it to run again.

      Attachments

        Activity

          fixed in version 1.13 (backward compatibility was broken)

          antoine_aumjaud Antoine Aumjaud added a comment - fixed in version 1.13 (backward compatibility was broken)
          eschepp Ernst Schepp added a comment -

          Thanks Antoine!
          I will try it out as soon as it is ready for download in the Plugin Manager.

          eschepp Ernst Schepp added a comment - Thanks Antoine! I will try it out as soon as it is ready for download in the Plugin Manager.

          People

            antoine_aumjaud Antoine Aumjaud
            eschepp Ernst Schepp
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: