Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2846

ClearCase Plugin remove/create does not work

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: Windows XP

    Description

      In Issue 2737 the option to update or remove/create was implemented.

      The update only case is working fine.

      It is not working for remove/create. If I do not tick the checkbox in the
      configuration it removes the view and creates the view but no files will be
      loaded by clearcase.

      "started
      [workspace] $ "C:\Program Files\Rational\ClearCase\bin\cleartool" rmview -force
      Project
      Removing references from VOB "\PROJECT_P" ...
      Removed references to view "O:\jobs\PROJECT91\workspace\PROJECT" from
      VOB "\PROJECT_P".
      [workspace] $ "C:\Program Files\Rational\ClearCase\bin\cleartool" mkview -
      snapshot -stream PROJECT_9.1_Dev@\PROJECT_P -tag PROJECT -vws
      CL5151
      \CCviews\PROJECT91_H.vws PROJECT
      Created view.
      Host-local path: CL5151:C:\Program Files\Rational\CCviews\PROJECT91_H.vws
      Global path: \\CL5151\CCviews\PROJECT91_H.vws
      Created snapshot view directory "PROJECT".
      Attached view to stream "PROJECT_9.1_Dev".
      [PROJECT] $ "C:\Program Files\Rational\ClearCase\bin\cleartool" lshistory -r -
      since 14-jan.14:44:48 -fmt '\"%Nd\" \"%En\" \"%Vn\" \"%[activity]p\" \"%e\" \"%
      o\" \n%c\n' -branch brtype:PROJECT_9.1_Dev -nco PROJECT_C\project
      FATAL: Unable to find build script at O:\jobs\PROJECT91
      \workspace\PROJECT\PROJECT_C\project\Client\dev\ch.swisslife.evtl\build\build.xm
      l
      finished: FAILURE
      "

      Attachments

        Issue Links

          Activity

            Code changed in hudson
            User: : sunfire
            Path:
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/UcmSnapshotCheckoutAction.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=14492
            Log:
            FIXED JENKINS-2846

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sunfire Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/UcmSnapshotCheckoutAction.java http://fisheye4.cenqua.com/changelog/hudson/?cs=14492 Log: FIXED JENKINS-2846
            sunfire sunfire added a comment -

            Fixed

            sunfire sunfire added a comment - Fixed
            heikof heikof added a comment -

            Thanks for the quick fix.

            heikof heikof added a comment - Thanks for the quick fix.
            sunfire sunfire added a comment -
                • Issue 3379 has been marked as a duplicate of this issue. ***
            sunfire sunfire added a comment - Issue 3379 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment -

            Marking as verified - fixed in 0.8.2.

            abayer Andrew Bayer added a comment - Marking as verified - fixed in 0.8.2.

            People

              sunfire sunfire
              heikof heikof
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: