Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2892

Cannot find setter nor field in org.apache.maven.plugins.site.SiteMojo for 'xmlOutput'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Builds are failing with exception: Cannot find setter nor field in
      org.apache.maven.plugins.site.SiteMojo for 'xmlOutput'

      This applies to jobs with checked "Publish FindBugs analysis results".

      Environment:
      Hudson 1.276
      FindBugs Plugin 3.2
      Maven 2.0.9

      Workarounds:

      • either uncheck "Publish FindBugs analysis results"
      • or downgrade FindBugs Plugin to version 3.1

      Stack trace:
      org.apache.maven.lifecycle.LifecycleExecutionException: Error configuring:
      org.apache.maven.plugins:maven-site-plugin. Reason: Unable to parse the created
      DOM for plugin configuration
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals
      (DefaultLifecycleExecutor.java:587)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle
      (DefaultLifecycleExecutor.java:499)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal
      (DefaultLifecycleExecutor.java:478)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures
      (DefaultLifecycleExecutor.java:330)
      at
      org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments
      (DefaultLifecycleExecutor.java:291)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute
      (DefaultLifecycleExecutor.java:142)
      at org.apache.maven.lifecycle.LifecycleExecutorInterceptor.execute
      (LifecycleExecutorInterceptor.java:42)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:287)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke
      (NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke
      (DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at hudson.maven.agent.Main.launch(Main.java:135)
      at hudson.maven.MavenBuilder.call(MavenBuilder.java:139)
      at hudson.maven.MavenModuleSetBuild$Builder.call
      (MavenModuleSetBuild.java:542)
      at hudson.maven.MavenModuleSetBuild$Builder.call
      (MavenModuleSetBuild.java:488)
      at hudson.remoting.UserRequest.perform(UserRequest.java:69)
      at hudson.remoting.UserRequest.perform(UserRequest.java:23)
      at hudson.remoting.Request$2.run(Request.java:213)
      at java.util.concurrent.Executors$RunnableAdapter.call
      (Executors.java:417)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
      at java.util.concurrent.FutureTask.run(FutureTask.java:123)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask
      (ThreadPoolExecutor.java:650)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run
      (ThreadPoolExecutor.java:675)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: org.apache.maven.plugin.PluginConfigurationException: Error
      configuring: org.apache.maven.plugins:maven-site-plugin. Reason: Unable to
      parse the created DOM for plugin configuration
      at org.apache.maven.plugin.DefaultPluginManager.populatePluginFields
      (DefaultPluginManager.java:1288)
      at org.apache.maven.plugin.DefaultPluginManager.getConfiguredMojo
      (DefaultPluginManager.java:661)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo
      (DefaultPluginManager.java:429)
      at hudson.maven.agent.PluginManagerInterceptor.executeMojo
      (PluginManagerInterceptor.java:159)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals
      (DefaultLifecycleExecutor.java:558)
      ... 28 more
      Caused by:
      org.codehaus.plexus.component.configurator.ComponentConfigurationException:
      Cannot find setter nor field in org.apache.maven.plugins.site.SiteMojo
      for 'xmlOutput'
      at
      org.codehaus.plexus.component.configurator.converters.ComponentValueSetter.<init
      >(ComponentValueSetter.java:68)
      at
      org.codehaus.plexus.component.configurator.converters.composite.ObjectWithFields
      Converter.processConfiguration(ObjectWithFieldsConverter.java:134)
      at
      org.codehaus.plexus.component.configurator.BasicComponentConfigurator.configureC
      omponent(BasicComponentConfigurator.java:56)
      at hudson.maven.agent.ComponentConfiguratorFilter.configureComponent
      (ComponentConfiguratorFilter.java:26)
      at
      hudson.maven.agent.PluginManagerInterceptor$MojoIntercepter.configureComponent
      (PluginManagerInterceptor.java:123)
      at org.apache.maven.plugin.DefaultPluginManager.populatePluginFields
      (DefaultPluginManager.java:1282)
      ... 32 more

        Attachments

          Issue Links

            Activity

            drulli Ulli Hafner added a comment -

            Duplicate.

                • This issue has been marked as a duplicate of 2880 ***

              People

              Assignee:
              drulli Ulli Hafner
              Reporter:
              vojtechhabarta vojtechhabarta
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: