Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-29088

Clicking on the “You can define the default values for the trend graph in a separate view.” for “Trend Graph” link results in HTTP ERROR 404.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: cpptest-plugin
    • Labels:
      None
    • Environment:
      Jenkins
      CppTest Plugin v0.13.2
    • Similar Issues:

      Description

      There is an issue with the post build action “Publish Cpptest analysis results” of the Cpptest plugin version 0.13.2. Clicking on the “You can define the default values for the trend graph in a separate view.” for “Trend Graph” link results in HTTP ERROR 404.
      Steps to reproduce.
      1. Create a new job or edit an existing one.
      2. Add post-build action “Publish Cpptest analysis results”.
      3. Click on the “Advanced” button.
      4. Check “Compute new warnings (based on the last successful build unless another reference build is chosen below)”.
      5. Add a 0 to “All Priorities” box under “Status thresholds (New warnings)”.
      6. Click “Save”
      7. Now edit the job and go to the “Publish Cpptest analysis results” section.
      8. Click the “Advanced” button.
      9. You should now see the “Trend graph” section and link “You can define the default values for the trend graph in a separate view.”
      10. Click on the link “You can define the default values for the trend graph in a separate view.”
      11. Results in HTTP ERROR 404.

        Attachments

          Issue Links

            Activity

            amuniz Antonio Muñiz added a comment -

            Gregory Boissinot I'm going to work in this issue. Do you mind if I assign it to myself?

            amuniz Antonio Muñiz added a comment -

            Two tests added:
            1. Run a build after copying an input XML file to workspace and check the result.
            2. Check that the 404 is solved (using WebClient).

            An increase of the core dependency was needed (to 1.480) since 1.410 was raising an exception that prevents to use WebClient in tests (probably related to JENKINS-8854).

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Antonio Muñiz
            Path:
            src/main/resources/hudson/plugins/cpptest/CpptestPublisher/config.jelly
            http://jenkins-ci.org/commit/cpptest-plugin/75ab10c9d1e37816da38e45e68389c52744be987
            Log:
            JENKINS-29088 Fix 404 on treds configuration link

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Antonio Muñiz
            Path:
            pom.xml
            src/test/java/hudson/plugins/cpptest/functional/CpptestPublisherTest.java
            http://jenkins-ci.org/commit/cpptest-plugin/e1fe0fb234cf9e03fe26ed2341742eb4cda13ca0
            Log:
            JENKINS-29088 Add 2 new tests: general publisher run inside a job + check that 404 is solved in trends link

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Gregory Boissinot
            Path:
            pom.xml
            src/main/resources/hudson/plugins/cpptest/CpptestPublisher/config.jelly
            src/test/java/hudson/plugins/cpptest/functional/CpptestPublisherTest.java
            http://jenkins-ci.org/commit/cpptest-plugin/65d6348edb48fd973d8fe248aa53a9ef13d8becc
            Log:
            Merge pull request #9 from amuniz/trend-config-JENKINS-29088

            JENKINS-29088 Fix 404 on trends configuration link

            Compare: https://github.com/jenkinsci/cpptest-plugin/compare/bca40df150bb...65d6348edb48


              People

              Assignee:
              amuniz Antonio Muñiz
              Reporter:
              jtsweet James Sweet
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: