Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-2939

UCM 0.8.2: cannot build windows slave matrix if master is unix and vice versa

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: All

    Description

      Using plugin 0.8.2-snapshot and hudson 1.278
      master: solaris 10
      slave: windows xp

      Configure a matrix build to run on the slave using write a windows style stream
      selector for the stream e.g. shared_development_2_0_4@\UCM_project

      Before hudson will try to start the matrix configurations on the slave, it will
      first perform a checkout on the master workspace.

      This does not work since the stream selector is written in windows style and not
      in unix style.(where I would need to write the selector as
      shared_development_2_0_4@/vobs/UCM_project)

      Two possible fixes:

      • hudson stops doing the extra master checkout. This solves the current case,
        but cross platform matrix builds still wont work
      • clearcase pluing understands the os type and adjust the selector accordingly

      Attachments

        Activity

          Code changed in hudson
          User: : sunfire
          Path:
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/DynamicCheckoutAction.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/SnapshotCheckoutAction.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/util/WindowsUnixConversion.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/SnapshotCheckoutActionTest.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=15571
          Log:
          JENKINS-2939

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sunfire Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/DynamicCheckoutAction.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/SnapshotCheckoutAction.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/util/WindowsUnixConversion.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/SnapshotCheckoutActionTest.java http://fisheye4.cenqua.com/changelog/hudson/?cs=15571 Log: JENKINS-2939
          sunfire sunfire added a comment -

          Possible fix will be release in 0.8.2

          sunfire sunfire added a comment - Possible fix will be release in 0.8.2
          sunfire sunfire added a comment -
              • Issue 3098 has been marked as a duplicate of this issue. ***
          sunfire sunfire added a comment - Issue 3098 has been marked as a duplicate of this issue. ***

          Code changed in hudson
          User: : sunfire
          Path:
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolLauncher.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolSnapshot.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/HudsonClearToolLauncher.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/DynamicCheckoutAction.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/SnapshotCheckoutAction.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolExecTest.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolSnapshotTest.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=15784
          Log:
          JENKINS-2939

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sunfire Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolLauncher.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolSnapshot.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/HudsonClearToolLauncher.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/DynamicCheckoutAction.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/action/SnapshotCheckoutAction.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolExecTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearToolSnapshotTest.java http://fisheye4.cenqua.com/changelog/hudson/?cs=15784 Log: JENKINS-2939

          Code changed in hudson
          User: : sunfire
          Path:
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/util/PathUtil.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/DynamicCheckoutActionTest.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/SnapshotCheckoutActionTest.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/util/PathUtilTest.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=15825
          Log:
          JENKINS-2939

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sunfire Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/util/PathUtil.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/DynamicCheckoutActionTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/SnapshotCheckoutActionTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/util/PathUtilTest.java http://fisheye4.cenqua.com/changelog/hudson/?cs=15825 Log: JENKINS-2939

          Code changed in hudson
          User: : sunfire
          Path:
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/util/PathUtil.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/DynamicCheckoutActionTest.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/SnapshotCheckoutActionTest.java
          trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/util/PathUtilTest.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=15827
          Log:
          JENKINS-2939

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sunfire Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/util/PathUtil.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/DynamicCheckoutActionTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/action/SnapshotCheckoutActionTest.java trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/util/PathUtilTest.java http://fisheye4.cenqua.com/changelog/hudson/?cs=15827 Log: JENKINS-2939
          abayer Andrew Bayer added a comment -

          Marking as verified - fixed in 0.8.2.

          abayer Andrew Bayer added a comment - Marking as verified - fixed in 0.8.2.

          People

            sunfire sunfire
            lynggaard lynggaard
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: