Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3186

Use existing dynamic views where the HUDSON_HOME directory contains a space

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: All

    Description

      For Windows platform, if you execute Hudson in a directory with a space, the
      option "Use existing dynamic view" doesn't work (its works for snapshot view)

      started
      [workspace] $ cleartool startview build_P_ChangeMgt_V3.2.1_int
      [build_P_ChangeMgt_V3.2.1_int] $ cleartool chstream -generate
      stream_ChangeMgt_V3.2.1_int@\P_ORC
      Changed stream "stream_ChangeMgt_V3.2.1_int@\P_ORC".
      [workspace] $ cleartool setcs -tag build_P_ChangeMgt_V3.2.1_int -stream
      [build_P_ChangeMgt_V3.2.1_int] $ cleartool lsproject -cview -fmt %[mod_comps]Xp
      Failed to create baseline: java.io.IOException: Cannot run program "cleartool"
      (in directory "C:\Documents and Settings\s0011918\.hudson\jobs\test3
      \workspace\build_P_ChangeMgt_V3.2.1_int"): CreateProcess error=267, The
      directory name is invalid
      finished: FAILURE

      Attachments

        Activity

          Ok, I am wrong.
          The problem is not in the space for the HUDSON_HOME directory.
          The problem is deeper.
          In the case of existing dynamic view, you use, the command is cleartool
          lsproject -cview -fmt %[mod_comps]Xp and this command is executed in
          $WORKSPACE\dynViewName. The source code is the same for snapshot view

          So, certainly, it’s will not work.
          It’s a dynamic view, so the working directory should be like M:\dynViewName

          How it’s works for your cases? Is there a special parametrization?

          So, my solution is to not use the "-cview" argument and execute the command in
          the workpace root with the "view" argument and the "dynViewName" like value

          gbois Gregory Boissinot added a comment - Ok, I am wrong. The problem is not in the space for the HUDSON_HOME directory. The problem is deeper. In the case of existing dynamic view, you use, the command is cleartool lsproject -cview -fmt % [mod_comps] Xp and this command is executed in $WORKSPACE\dynViewName. The source code is the same for snapshot view So, certainly, it’s will not work. It’s a dynamic view, so the working directory should be like M:\dynViewName How it’s works for your cases? Is there a special parametrization? So, my solution is to not use the "-cview" argument and execute the command in the workpace root with the "view" argument and the "dynViewName" like value

          Created an attachment (id=591)
          Support dynamic view UCM with baseline creation - proposal

          gbois Gregory Boissinot added a comment - Created an attachment (id=591) Support dynamic view UCM with baseline creation - proposal

          Is there any others elements you need for apply this patch
          Thanks

          gbois Gregory Boissinot added a comment - Is there any others elements you need for apply this patch Thanks

          Code changed in hudson
          User: : sunfire
          Path:
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmMakeBaseline.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=16716
          Log:
          JENKINS-3304
          JENKINS-3186

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : sunfire Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ucm/UcmMakeBaseline.java http://fisheye4.cenqua.com/changelog/hudson/?cs=16716 Log: JENKINS-3304 JENKINS-3186
          sunfire sunfire added a comment -

          Patched and ready for test

          sunfire sunfire added a comment - Patched and ready for test

          Test is OK with windows platform, latest clearcase trunk and hudson core 1.299.

          Note: A load rule must not start with '\'
          like 'ORCHESTRA\ThalesControl_Orchestra' where 'ORCHESTRA' is the vob
          and 'ThalesControl' is the component.

          I will test on Linux (Read Hat 5) next week.

          gbois Gregory Boissinot added a comment - Test is OK with windows platform, latest clearcase trunk and hudson core 1.299. Note: A load rule must not start with '\' like 'ORCHESTRA\ThalesControl_Orchestra' where 'ORCHESTRA' is the vob and 'ThalesControl' is the component. I will test on Linux (Read Hat 5) next week.

          Test is OK on Linux too

          In my opinion, the issue can be closed.

          gbois Gregory Boissinot added a comment - Test is OK on Linux too In my opinion, the issue can be closed.
          sunfire sunfire added a comment -

          VERIFIED

          sunfire sunfire added a comment - VERIFIED

          People

            sunfire sunfire
            gbois Gregory Boissinot
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: