Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-32049

Labels Dashboard is not showing any Labels and any Nodes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins ver. 1.625.2
      Label Linked Jobs Plugin 4.0.2
    • Similar Issues:

      Description

      Labels Dashboard is showing no Labels and no Nodes (see screenshot).

      The problem has appeared when I migrated the Jenkins Master to an another server and updated from Jenkins 1.601 to 1.625.2.

      The labels handling and labels dependend execution of jobs is still working. I can also view the information about the singular labels with http://jenkins.<site>.net/label/<label>/. Only the view on the Dashboard is not working.

        Attachments

          Activity

          olibolib m r added a comment -

          Yes, this is truth, I have also switched from java 1.7 to 1.8.
          Sorry for not mention this.

          scm_issue_link SCM/JIRA link daemon added a comment -

          Code changed in jenkins
          User: Dominique
          Path:
          .gitignore
          src/main/java/jenkins/plugins/linkedjobs/helpers/TriggeredJobsHelper.java
          http://jenkins-ci.org/commit/label-linked-jobs-plugin/1842c5b0ff155677f05dd6678f50d3b905fd7e6c
          Log:
          JENKINS-32049 ConcurrentModificationException

          dominiquebrice Dominique Brice added a comment - - edited

          I wasn't able to reproduce the issue, which may occur only with specific JVM implementations (I tested with jdk1.7.0_79 and jdk1.8.0_65 on Mac OS 10.11.2). It could behave differently on Windows, Linux, etc.
          In the plugin the problem becomes apparent when a job is configured via/for the Parameterized Trigger Plugin with the $ syntax (to specify a macro).
          In any case, I have a good hunch as to what's causing the problem and I created release 4.0.3 with the specific fix.
          m r since I can't test in my development environment I would appreciate if you could confirm whether it work for you (yeah!) or not (please provide logs in that case ). Thanks!

          olibolib m r added a comment -

          Great! Release 4.0.3 works as expected. The bug is fixed. There are also no more exceptions within the logs.

          Thanks a lot!!!

          dominiquebrice Dominique Brice added a comment -

          thanks for your feedback!


            People

            Assignee:
            dominiquebrice Dominique Brice
            Reporter:
            olibolib m r
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: