Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3359

404 error when browsing JUnit results

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Duplicate
    • junit-plugin
    • None
    • Platform: PC, OS: Windows XP

    Description

      Tomcat returns 404 error if there is a # character in the name of testcase:
      JUnit XML result:
      testcase name="en.test#00-24" classname="en.test#00-24" time="0">
      <failure message="AssertionFailedError: expected:8, but was:1"
      type="AssertionFailedError"/>
      </testcase>

      The URL to test result in this case looks like
      http://localhost:8080/hudson/job/my-
      project/lastBuild/testReport/en.test/test#00-24/en_test_test_00_24

      Attachments

        Issue Links

          Activity

            kutzi kutzi added a comment -

            Looks like a duplicate of JENKINS-10458 to me

            kutzi kutzi added a comment - Looks like a duplicate of JENKINS-10458 to me

            People

              Unassigned Unassigned
              sotnikova sotnikova
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: