Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-35075

Credentials Plugin 2.x breaks node configuration page

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: credentials-plugin
    • Labels:
      None
    • Environment:
      Windows Jenkins 1.651.2
    • Similar Issues:

      Description

      When I upgrade the Credentials Plugin to version 2.0 or later, I can no longer add new nodes or reconfigure existing nodes.

      Steps to reproduce...

      1. Do fresh install of Jenkins 1.651.2 on Windows
      2. Verify that you can add a new slave node and reconfigure an existing node
      3. Upgrade Credentials Plugin to version 2.0 or 2.0.1
      4. Attempt to add a new node or reconfigure an existing node
      5. Node configuration page never comes up

      FYI, I do not see any relevant error messages in jenkins.out.log or jenkins.err.log.

      Note that Credentials Plugin version 1.28 does not cause this bad behavior.

        Attachments

          Issue Links

            Activity

            Hide
            stephenconnolly Stephen Connolly added a comment -

            Should be available in the update center within the next 24h or can be downloaded directly from http://jenkins-updates.cloudbees.com/download/plugins/credentials/2.0.3/credentials.hpi if you need it before the update center sync

            Show
            stephenconnolly Stephen Connolly added a comment - Should be available in the update center within the next 24h or can be downloaded directly from http://jenkins-updates.cloudbees.com/download/plugins/credentials/2.0.3/credentials.hpi if you need it before the update center sync
            Hide
            stephenconnolly Stephen Connolly added a comment -

            fixed in 2.0.3

            Show
            stephenconnolly Stephen Connolly added a comment - fixed in 2.0.3
            Hide
            aasimid Makis Asimidis added a comment -

            I have the exact same issue at both Jenkins 2.6 and the 1.651.2 LTS version. With credentials plugin 2.05 I get a javascript loading error that makes my job editing screens hung indefinitely which led me to downgrade to credentials v2.0, in which in turn I am now facing this issue.

            Show
            aasimid Makis Asimidis added a comment - I have the exact same issue at both Jenkins 2.6 and the 1.651.2 LTS version. With credentials plugin 2.05 I get a javascript loading error that makes my job editing screens hung indefinitely which led me to downgrade to credentials v2.0, in which in turn I am now facing this issue.
            Hide
            stephenconnolly Stephen Connolly added a comment -

            2.0.6

            Show
            stephenconnolly Stephen Connolly added a comment - 2.0.6
            Hide
            aasimid Makis Asimidis added a comment -

            I confirm 2.06 eliminates both issues I reported above

            Show
            aasimid Makis Asimidis added a comment - I confirm 2.06 eliminates both issues I reported above

              People

              Assignee:
              stephenconnolly Stephen Connolly
              Reporter:
              kcurrier Keith Currier
              Votes:
              2 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: