Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3556

0.8.2 - NPE getting excluded regions with existing jobs

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: All

    Description

      Looks like the excluded regions preference is null for existing jobs and the 0.8.2 doesn't expect this.

      java.lang.NullPointerException
      at
      hudson.plugins.clearcase.AbstractClearCaseScm.getExcludedRegionsNormalized(AbstractClearCaseScm.java:405)
      at hudson.plugins.clearcase.AbstractClearCaseScm.configureFilters(AbstractClearCaseScm.java:413)
      at hudson.plugins.clearcase.ClearCaseSCM.createHistoryAction(ClearCaseSCM.java:194)
      at hudson.plugins.clearcase.AbstractClearCaseScm.checkout(AbstractClearCaseScm.java:261)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:807)
      at hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:313)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:265)
      at hudson.model.Run.run(Run.java:899)
      at hudson.model.Build.run(Build.java:112)
      at hudson.model.ResourceController.execute(ResourceController.java:93)
      at hudson.model.Executor.run(Executor.java:119)

      Attachments

        Issue Links

          Activity

            abayer Andrew Bayer added a comment -

            That's my fault - sorry. We'll probably be rolling out a quick 0.8.3 pretty
            soon, which will include a fix for this. In the meantime, you can fix individual
            jobs by going to Configure for them and saving - that should get the empty
            string in there for the excluded regions value.

            abayer Andrew Bayer added a comment - That's my fault - sorry. We'll probably be rolling out a quick 0.8.3 pretty soon, which will include a fix for this. In the meantime, you can fix individual jobs by going to Configure for them and saving - that should get the empty string in there for the excluded regions value.

            Code changed in hudson
            User: : abayer
            Path:
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=17432
            Log:
            [FIXED JENKINS-3556] Changed getExcludedRegionsNormalized to avoid NPEs in pre-0.8.2 jobs.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java http://fisheye4.cenqua.com/changelog/hudson/?cs=17432 Log: [FIXED JENKINS-3556] Changed getExcludedRegionsNormalized to avoid NPEs in pre-0.8.2 jobs.
            sunfire sunfire added a comment -
                • Issue 3563 has been marked as a duplicate of this issue. ***
            sunfire sunfire added a comment - Issue 3563 has been marked as a duplicate of this issue. ***

            People

              abayer Andrew Bayer
              tonychan tonychan
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: