Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-3622

ClearCase polling issues

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: Linux

    Description

      It looks like my clearcase polling is finding changes but not kicking off
      a build all of the sudden? The only change I made was to move the Hudson
      home to a filer network drive path (clearcase views still on local disk
      though via symlink under the workspace folder). I rebuilt the hudson
      server from scratch but that didnt help. Is running hudson off a filer
      causing tmy polling issues? Please see below for a recent polling log that
      didnt fire a build..

      Re-created my views, restarted hudson. Still no luck. The clearase polling is
      still finding changes but not kicking off builds. Maybe I should just revert
      my hudson war & clearcase plugin to the older versions?

      Attachments

        Issue Links

          Activity

            anthonyj anthonyj added a comment -

            Created an attachment (id=685)
            one job which isnt firing new builds

            anthonyj anthonyj added a comment - Created an attachment (id=685) one job which isnt firing new builds
            abayer Andrew Bayer added a comment -

            Think I found the problem - doing some testing locally.

            abayer Andrew Bayer added a comment - Think I found the problem - doing some testing locally.
            abayer Andrew Bayer added a comment -

            Yes, I did. It was entirely my fault. If no excluded regions were defined, it
            was rejecting everything. D'oh. I'm committing a fix now (along with a
            rollback of issue 3559, which I think broke things in a different way). If you'd
            be willing, I'd like it if you could try the clearcase.hpi I'll be attaching
            here, an 0.8.4-SNAPSHOT build I ran, to see if it works for you. If so, I'll
            push out a release later today.

            abayer Andrew Bayer added a comment - Yes, I did. It was entirely my fault. If no excluded regions were defined, it was rejecting everything . D'oh. I'm committing a fix now (along with a rollback of issue 3559, which I think broke things in a different way). If you'd be willing, I'd like it if you could try the clearcase.hpi I'll be attaching here, an 0.8.4-SNAPSHOT build I ran, to see if it works for you. If so, I'll push out a release later today.
            abayer Andrew Bayer added a comment -

            Created an attachment (id=687)
            0.8.4-SNAPSHOT, should fix the problem

            abayer Andrew Bayer added a comment - Created an attachment (id=687) 0.8.4-SNAPSHOT, should fix the problem

            Code changed in hudson
            User: : abayer
            Path:
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=17760
            Log:
            JENKINS-3622 - checking for empty string before creating an exclusion filter. Also rolled back 3556, which I think would have caused problems as well.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolExec.java http://fisheye4.cenqua.com/changelog/hudson/?cs=17760 Log: JENKINS-3622 - checking for empty string before creating an exclusion filter. Also rolled back 3556, which I think would have caused problems as well.
            abayer Andrew Bayer added a comment -
                • Issue 3631 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment - Issue 3631 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment -

            Ok, the change I made did fix it. I'll be releasing 0.8.4 shortly.

            abayer Andrew Bayer added a comment - Ok, the change I made did fix it. I'll be releasing 0.8.4 shortly.

            People

              abayer Andrew Bayer
              anthonyj anthonyj
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: