Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-38692

Add extra fine grained logging to JNLPv4 protocol

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved (View Workflow)
    • Minor
    • Resolution: Done
    • remoting
    • None

    Description

      In discovering JENKINS-38690 and JENKINS-38691 I had to add extra logging to the code.
      Given that this is exceptionally useful logging to be able to turn on it should be added to the code if it does not have a significant performance degredation.

      Attachments

        Issue Links

          Activity

            Code changed in jenkins
            User: James Nord
            Path:
            src/main/java/org/jenkinsci/remoting/protocol/IOHub.java
            src/main/java/org/jenkinsci/remoting/protocol/impl/NIONetworkLayer.java
            http://jenkins-ci.org/commit/remoting/46c72a5530a0b2757350e33262ae17c981dcd13a
            Log:
            JENKINS-38692 Add extra logging to help diagnosing Thread spike. (#116)

            Add extra logging statements to try and get to the root cause
            of the IOHub thread spike.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: James Nord Path: src/main/java/org/jenkinsci/remoting/protocol/IOHub.java src/main/java/org/jenkinsci/remoting/protocol/impl/NIONetworkLayer.java http://jenkins-ci.org/commit/remoting/46c72a5530a0b2757350e33262ae17c981dcd13a Log: JENKINS-38692 Add extra logging to help diagnosing Thread spike. (#116) Add extra logging statements to try and get to the root cause of the IOHub thread spike.
            oleg_nenashev Oleg Nenashev added a comment -

            The fix has been integrated towards remoting-3.1

            oleg_nenashev Oleg Nenashev added a comment - The fix has been integrated towards remoting-3.1

            Code changed in jenkins
            User: Oleg Nenashev
            Path:
            pom.xml
            http://jenkins-ci.org/commit/jenkins/7a948d399585d201c4132597aed5723a495acf69
            Log:
            Update remoting to 2.31 in the Jenkins core. (#2628)

            The change introduces one serious bugfix (JENKINS-39596) and a bunch of various diagnostics improvements.

            Bugfixes:

            Improvements:

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: Oleg Nenashev Path: pom.xml http://jenkins-ci.org/commit/jenkins/7a948d399585d201c4132597aed5723a495acf69 Log: Update remoting to 2.31 in the Jenkins core. (#2628) The change introduces one serious bugfix ( JENKINS-39596 ) and a bunch of various diagnostics improvements. Bugfixes: JENKINS-39596 ( https://issues.jenkins-ci.org/browse/JENKINS-39596 ) - Jenkins URL in `hudson.remoting.Engine` was always `null` since `3.0`. It was causing connection failures of Jenkins JNLP agents when using Java Web Start. ( PR #131 ( https://github.com/jenkinsci/remoting/pull/131 )) JENKINS-39617 ( https://issues.jenkins-ci.org/browse/JENKINS-39617 ) - `hudson.remoting.Engine` was failing to establish connection if one of the URLs parameter in parameters was malformed. ( PR #131 ( https://github.com/jenkinsci/remoting/pull/131 )) Improvements: JENKINS-39150 ( https://issues.jenkins-ci.org/browse/JENKINS-39150 ) - Add logic for dumping diagnostics across all the channels. ( PR #122 ( https://github.com/jenkinsci/remoting/pull/122 ), PR #125 ( https://github.com/jenkinsci/remoting/pull/125 )) JENKINS-39543 ( https://issues.jenkins-ci.org/browse/JENKINS-39543 ) - Improve the caller/callee correlation diagnostics in thread dumps. ( PR #119 ( https://github.com/jenkinsci/remoting/pull/119 )) JENKINS-39290 ( https://issues.jenkins-ci.org/browse/JENKINS-39290 ) - Add the `org.jenkinsci.remoting.nio.NioChannelHub.disabled` flag for disabling NIO (mostly for debugging purposes). ( PR #123 ( https://github.com/jenkinsci/remoting/pull/123 )) JENKINS-38692 ( https://issues.jenkins-ci.org/browse/JENKINS-38692 ) - Add extra logging to help diagnosing `IOHub` Thread spikes. ( PR #116 ( https://github.com/jenkinsci/remoting/pull/116 )) JENKINS-39289 ( https://issues.jenkins-ci.org/browse/JENKINS-39289 ) - When a proxy fails, report what caused the channel to go down. ( PR #128 ( https://github.com/jenkinsci/remoting/pull/128 ))
            oleg_nenashev Oleg Nenashev added a comment -

            The fix has been integrated towards jenkins-2.31

            oleg_nenashev Oleg Nenashev added a comment - The fix has been integrated towards jenkins-2.31

            People

              Unassigned Unassigned
              teilo James Nord
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: