Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-41512

CSS width problem with credentials dropdown

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: credentials-plugin
    • Labels:
      None
    • Environment:
      Chrome 55, credentials-plugin v.2.1.10
    • Similar Issues:

      Description

      When the credential select field is visible in the configuration page of the job, the right table column does not shrink properly when a long name credential is selected.
      This is caused by a "width: auto" in select.css. Disabling (or setting to 100%) this directive for select.credentials-select fixes the problem for me (see second screenshot).

        Attachments

        1. 2017-01-27_13h21_29.png
          2017-01-27_13h21_29.png
          118 kB
        2. 2017-01-27_13h21_45.png
          2017-01-27_13h21_45.png
          114 kB
        3. screenshot-1.png
          screenshot-1.png
          56 kB
        4. screenshot-2.png
          screenshot-2.png
          55 kB

          Issue Links

            Activity

            gusreiber gus reiber added a comment -

            Stephen Connolly, I am sorry, I don't have a CSS silver bullet for you. You are already dynamically changing the max-width on the select box with Jquery, which is already pretty drastic. You could similarly dynamically trim characters from the option boxes or restrict the number of characters you allow when the original value is created. Otherwise, the entire form HTML needs to be overhauled.

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            src/main/resources/lib/credentials/select/select.css
            http://jenkins-ci.org/commit/credentials-plugin/7a413bd933ce8e3edb1f991f138cc27bfd284d6d
            Log:
            JENKINS-41512 Use @media query to scale select max-width

            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in jenkins
            User: Stephen Connolly
            Path:
            src/main/resources/lib/credentials/select/select.css
            http://jenkins-ci.org/commit/credentials-plugin/d8a11ad108ad3b5e66c83401fcf212297092efd4
            Log:
            Merge pull request #80 from stephenc/jenkins-41512

            JENKINS-41512 Use @media query to scale select max-width

            Compare: https://github.com/jenkinsci/credentials-plugin/compare/51583db72282...d8a11ad108ad

            ccschneidr Christian Schneider added a comment -

            Well, actually the problem is not "fixed". It would take too much effort to overhaul the css/html, obviously. But this would make it a "won't fix", right?

            stephenconnolly Stephen Connolly added a comment -

            Well it was fixed as best it can be back in March... just didn't get around to closing out the issue


              People

              Assignee:
              stephenconnolly Stephen Connolly
              Reporter:
              ccschneidr Christian Schneider
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: