Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4526

Incorrect view path with slaves when slave os doesn't match master os.

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Minor
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: All

    Description

      We're running a setup with Hudson master on Windows with a Linux slave (ssh).
      We're using Clearcase and Maven and would like to use the built in support for
      these to get nicer output (rather than scripting it ourselves).

      Our problem is that the clearcase plugin inserts an extra (incorrect) \ in the
      view path.

      When we try to run the job on linux host sauron with view root = /view/, load
      rules=/vob/NYA_JAVA we get

      --CUT--
      Started by user anonymous
      Building remotely on sauron
      /view/sauron_mvn_v9
      element * CHECKEDOUT
      element * /main/version9/LATEST
      element * /main/0
      Parsing POMs
      ERROR: No such file /view/\sauron_mvn_v9/vob/NYA_JAVA/pom.xml
      Perhaps you need to specify the correct POM file path in the project configuration?
      Finished: FAILURE
      --CUT--

      (vob/NYA_JAVA/pom.xml comes from the Maven plugin)

      As far as I can make out the problem is the use of java.io.File.separator, which
      seems to be evaluated on the master (Windows) side, while the resulting string
      is used on Linux.

      Obvious potential workarounds:

      As it seems to be used only between the view drive/root and view name, don't add
      anything if view root ends with \ or /.

      Extra advanced setting for separator.

      I can submit a patching but am unsure which solution is considered the least ugly.

      Attachments

        Activity

          abayer Andrew Bayer added a comment -

          Fixed in trunk for 1.1.1.

          abayer Andrew Bayer added a comment - Fixed in trunk for 1.1.1.

          Code changed in hudson
          User: : abayer
          Path:
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java
          trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolDynamic.java
          http://fisheye4.cenqua.com/changelog/hudson/?cs=25744
          Log:
          [FIXED JENKINS-4526] Got rid of direct usage of File.separator.

          scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/AbstractClearCaseScm.java trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearToolDynamic.java http://fisheye4.cenqua.com/changelog/hudson/?cs=25744 Log: [FIXED JENKINS-4526] Got rid of direct usage of File.separator.

          People

            abayer Andrew Bayer
            pontusf pontusf
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: