Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-4575

UCM clearcase issue : brtype doesnt match stream name

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Blocker
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: Windows XP

    Description

      We have an issue wherein we have the branch type name different from the
      stream name. Since the job only accepts a stream name , the cleartool
      lshistory command fails since this requires a brtype name. In our case
      brtype is different then stream name. We had to do this since the path name
      was exceeding the limit
      eg. stream name : VSS_6.4.1_Int@\Y_PVOB
      brtype: v641i

      here is the error we get . Notice brtype is using stream name. Is there a
      workaround to use brtype instead
      [dkutty_vss_6_4_1_int8] $ cleartool lshistory -all -since
      28-sep-09.16:06:48utc+0000 -fmt '\"%Nd\" \"%u\" \"%En\" \"%Vn\" \"%e\"
      \"%o\" \"%[activity]p\" \n%c\n' -branch brtype:VSS_6.4.1_Int -nco MOM_VSS
      cleartool: Error: Branch type not found: "VSS_6.4.1_Int".
      FATAL: UCM ClearCase failed. exit code=1
      FATAL: cleartool did not return the expected exit code. Command
      line="lshistory -all -since 28-sep-09.16:06:48utc+0000 -fmt \"%Nd\" \"%u\"
      \"%En\" \"%Vn\" \"%e\" \"%o\" \"%[activity]p\" \n%c\n -branch
      brtype:VSS_6.4.1_Int -nco MOM_VSS", actual exit code=1
      java.io.IOException: cleartool did not return the expected exit code.
      Command line="lshistory -all -since 28-sep-09.16:06:48utc+0000 -fmt \"%Nd\"
      \"%u\" \"%En\" \"%Vn\" \"%e\" \"%o\" \"%[activity]p\" \n%c\n -branch
      brtype:VSS_6.4.1_Int -nco MOM_VSS", actual exit code=1
      at
      hudson.plugins.clearcase.HudsonClearToolLauncher.run(HudsonClearToolLauncher.java:100)
      at hudson.plugins.clearcase.ClearToolExec.lshistory(ClearToolExec.java:90)
      at
      hudson.plugins.clearcase.history.AbstractHistoryAction.runLsHistory(AbstractHistoryAction.java:81)
      at
      hudson.plugins.clearcase.history.AbstractHistoryAction.getChanges(AbstractHistoryAction.java:67)
      at
      hudson.plugins.clearcase.AbstractClearCaseScm.checkout(AbstractClearCaseScm.java:383)
      at hudson.model.AbstractProject.checkout(AbstractProject.java:974)
      at
      hudson.model.AbstractBuild$AbstractRunner.checkout(AbstractBuild.java:400)
      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:349)
      at hudson.model.Run.run(Run.java:1123)
      at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:46)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:123)

      Attachments

        Issue Links

          Activity

            Added myself to cc

            gbois Gregory Boissinot added a comment - Added myself to cc
            abayer Andrew Bayer added a comment -

            Should we maybe add a branch parameter to the UCM configuration, in the advanced
            options? If it's blank, still default to the stream name, but otherwise, use the
            given branch name? (as always, I need advice/pointers with UCM use cases)

            abayer Andrew Bayer added a comment - Should we maybe add a branch parameter to the UCM configuration, in the advanced options? If it's blank, still default to the stream name, but otherwise, use the given branch name? (as always, I need advice/pointers with UCM use cases)
            abayer Andrew Bayer added a comment -
                • Issue 4577 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment - Issue 4577 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment -
                • Issue 4578 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment - Issue 4578 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment -
                • Issue 4579 has been marked as a duplicate of this issue. ***
            abayer Andrew Bayer added a comment - Issue 4579 has been marked as a duplicate of this issue. ***

            Code changed in hudson
            User: : abayer
            Path:
            trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearCaseUcmSCM.java
            trunk/hudson/plugins/clearcase/src/main/resources/hudson/plugins/clearcase/ClearCaseUcmSCM/config.jelly
            trunk/hudson/plugins/clearcase/src/main/webapp/ucmbranchname.html
            trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMTest.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=22709
            Log:
            [FIXED JENKINS-4575] Added optional, advanced overrideBranchName parameter for UCM jobs.

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in hudson User: : abayer Path: trunk/hudson/plugins/clearcase/src/main/java/hudson/plugins/clearcase/ClearCaseUcmSCM.java trunk/hudson/plugins/clearcase/src/main/resources/hudson/plugins/clearcase/ClearCaseUcmSCM/config.jelly trunk/hudson/plugins/clearcase/src/main/webapp/ucmbranchname.html trunk/hudson/plugins/clearcase/src/test/java/hudson/plugins/clearcase/ClearCaseUcmSCMTest.java http://fisheye4.cenqua.com/changelog/hudson/?cs=22709 Log: [FIXED JENKINS-4575] Added optional, advanced overrideBranchName parameter for UCM jobs.

            People

              abayer Andrew Bayer
              dkutty dkutty
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: