Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-50910

Japex Plugin is not compatible with Jenkins 2.102+ due to serialization of weak references

    XMLWordPrintable

    Details

    • Similar Issues:

      Description

      https://github.com/jenkinsci/japex-plugin/blob/cb0225d2625361fdb69182282d8a834826ede829/src/main/java/hudson/plugins/japex/JapexReportAction.java#L56

      The cache is persisted to the disk, and it should not actually happen. It causes JEP-200 issues while serializing the action via XStream.

        Attachments

          Activity

          Hide
          oleg_nenashev Oleg Nenashev added a comment -

          Just to set an expectation, JEP-200 maintainers do not plan to fix this plugin. It has only 40 installations, and the code is outdated. The fix is trivial, but it just does not make sense unless there is somebody interested to maintain the plugin

          Show
          oleg_nenashev Oleg Nenashev added a comment - Just to set an expectation, JEP-200 maintainers do not plan to fix this plugin. It has only 40 installations, and the code is outdated. The fix is trivial, but it just does not make sense unless there is somebody interested to maintain the plugin

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            oleg_nenashev Oleg Nenashev
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated: