Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51696

Builds randomly fail on Kubernetes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Component/s: kubernetes-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.107.1
      kubernetes-plugin 1.7.0
    • Similar Issues:

      Description

      Hi

       

      I looked into all other issues about random fails but didn't find a similar case with Kubernetes 

       

      What's weird it's several of my pipelines work really well, and sometimes, without making a big change in the source code, or without making any change at all (replaying build), it may fail...

       

      Yesterday I had 2 kind of errors. I don't remember if there is more kind of errors but if it is I will update this post. Here they are:

       

      [XXXXXX_master-FNE77XPBBMZR7JA4YQLYUNAFC2YTKHBOAXYIR5V4XCHIXRKRUL6Q] Running shell script
      
      rpc error: code = 14 desc = grpc: the connection is unavailable
      
      process apparently never started in /XXXXXXXXXXXX/XXXXXX_master-FNE77XPBBMZR7JA4YQLYUNAFC2YTKHBOAXYIR5V4XCHIXRKRUL6Q@tmp/durable-cfbf838b
      
      script returned exit code -2
      

       

      The second one:

       

      [XXXXXX_master-FNE77XPBBMZR7JA4YQLYUNAFC2YTKHBOAXYIR5V4XCHIXRKRUL6Q] Running shell script
      
      + docker inspect -f . c7846108965a9110ff71051dc24fd338da381f89
      
      .
      
      java.lang.InterruptedException
      

       

      I'm wondering if someone could help me with that? Sorry that I have no more details to provide

       

      Thank you,

        Attachments

          Activity

          Hide
          csanchez Carlos Sanchez added a comment -

          what kubernetes installation?
          jenkins logs ?

          Show
          csanchez Carlos Sanchez added a comment - what kubernetes installation? jenkins logs ?
          Hide
          akamel1001 Ahmed Kamel added a comment - - edited

          Hey Carlos Sanchez,

          I seem to be having a similar problem.
          The cluster that is having this problem is GKE version 1.10.9. Please let me know if you have nay idea what might be causing this issue. 

          Show
          akamel1001 Ahmed Kamel added a comment - - edited Hey Carlos Sanchez , I seem to be having a similar problem. The cluster that is having this problem is GKE version 1.10.9. Please let me know if you have nay idea what might be causing this issue. 
          Hide
          vlatombe Vincent Latombe added a comment -

          Closing as stale. Feel free to re-open if you can reproduce the issue with a recent version of the plugin.

          Show
          vlatombe Vincent Latombe added a comment - Closing as stale. Feel free to re-open if you can reproduce the issue with a recent version of the plugin.

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            sneko Thomas Ramé
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: