Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51716

Blueocean stuck in loading

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: blueocean-plugin
    • Labels:
      None
    • Environment:
      Jenkins ver. 2.107.2
      Blue Ocean 1.5.0
    • Similar Issues:
    • Released As:
      1.14.0

      Description

      When I try to open blue ocean it's stuck in loading forever.

        Attachments

        1. Capture.PNG
          Capture.PNG
          48 kB
        2. data.json
          26 kB

          Issue Links

            Activity

            monger39 David Riemens added a comment -

            Gavin Mogan : I have updated all Blue Ocean plugins to 1.14.0 but the problem remains. I have tried using 3 browsers with identical result.
            The script console gives a number of errors. As asked I will open a new bug report.

            klm Ken Morse added a comment -

            Gavin Mogan - just confirmed that 1.14.0 does fix the problem I was seeing in Blue Ocean.

            lixiaod2 Li Xiaodong added a comment -

            Hi, I want to comment here since I have met the same issue in the ticket on Blue Ocean version 1.21.0 with Jenkins version 2.204.2

            The error in browser console is "Timed out waiting on module 'blueocean-pipeline-editor:jenkins-js-extension' to load."

            (anonymous) @ jenkins-js-extension.js:74075
            doFulfill @ jenkins-js-extension.js:3470
            onFulfilled @ jenkins-js-extension.js:3482
            508../../jenkins-js-extension.jsx @ jenkins-js-extension.js:74074
            o @ jenkins-js-extension.js:1
            r @ jenkins-js-extension.js:1
            (anonymous) @ jenkins-js-extension.js:1
            blueocean.js:58216 Unhandled Rejection: "Error: fetch failed: 503 for http://XXXXXXXX:8080/blue/rest/i18n/blueocean-pipeline-editor/1.21.0/jenkins.plugins.blueocean.pipeline.editor.Messages/en-US\n at FetchFunctions.checkStatus (http://XXXXXXXX:8080/adjuncts/25eb676d/io/jenkins/blueocean/blueocean-core-js.js:54923:25)"
            logUnhandledPromiseRejection @ blueocean.js:58216
            blueocean-core-js.js:2295 Module load failure: Timed out waiting on module 'blueocean-pipeline-editor:jenkins-js-extension' to load.
            (anonymous) @ blueocean-core-js.js:2295
            setTimeout (async)
            (anonymous) @ blueocean-core-js.js:2284

            And jenkins log will give the same error with David commented before:

            at io.jenkins.blueocean.auth.jwt.impl.JwtAuthenticationFilter.doFilter(JwtAuthenticationFilter.java:61) at io.jenkins.blueocean.auth.jwt.impl.JwtAuthenticationFilter.doFilter(JwtAuthenticationFilter.java:61) at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:151) at com.smartcodeltd.jenkinsci.plugin.assetbundler.filters.LessCSS.doFilter(LessCSS.java:47) at hudson.util.PluginServletFilter$1.doFilter(PluginServletFilter.java:151) at io.jenkins.blueocean.ResourceCacheControl.doFilter(ResourceCacheControl.java:134)

             

            If whole log is needed, I will add more.

            Could you please help to check whether this is a new issue or the ticket hasn't been solved completed?

             

            nh2 Niklas Hambuechen added a comment -

            Li Xiaodong For me, upgrading from Jenkins `2.204.2` to `2.222.1` (with Blue Ocean 1.23.2) fixed the hanging problem.


              People

              Assignee:
              halkeye Gavin Mogan
              Reporter:
              aosman A O
              Votes:
              1 Vote for this issue
              Watchers:
              15 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: