Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-51993

Failing to parse nunit 2 results file

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: xunit-plugin
    • Labels:
      None
    • Environment:
      xunit 2.0.2
      jenkins
    • Similar Issues:

      Description

      Upgraded to 2.0.2, still getting following error. Nunit 2 results file has few <test-suite> root attributes under root <test-results> and it fails on second root <test-suite> entry. Unfortunately i cannot paste a full nunit result report.

      INFO: Starting to record.
      INFO: Processing NUnit-2.x (default)
      INFO: [NUnit-2.x (default)] - 1 test report file(s) were found with the pattern 'tests/unit/TestResult.xml' relative to '/home/build/workspace/<redacted_path>' for the testing framework 'NUnit-2.x (default)'.
      WARNING: The file '/home/build/workspace/<redacted_path>/tests/unit/TestResult.xml' is an invalid file.
      WARNING: At line 1478 of file:/home/build/workspace/<redacted_path>/tests/unit/TestResult.xml:cvc-complex-type.2.4.d: Invalid content was found starting with element 'test-suite'. No child element is expected at this point.
      ERROR: The result file '/home/build/workspace/<redacted_path>/tests/unit/TestResult.xml' for the metric 'NUnit' is not valid. The result file has been skipped.
      INFO: Failing BUILD because 'set build failed if errors' option is activated.
      INFO: There are errors when processing test results.
      INFO: Skipping tests recording.
      INFO: Stop build.
      

        Attachments

          Activity

          nfalco Nikolas Falco added a comment -

          I need the original report file that cause the issue.

          In your previous issue I have use your attachment as new test case. The XSD comes from the NUnit 2.x distribution archives. It is strange the original tools produce something that does not respect their official schema.

          nfalco Nikolas Falco added a comment -

          Without the original report the issue could be reproduced.

          tomaxsas Tomas Zaleniakas added a comment -

            People

            Assignee:
            nfalco Nikolas Falco
            Reporter:
            tomaxsas Tomas Zaleniakas
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: