Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52135

Resource disposer plugin 0.9 causes jobs to fail

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Labels:
      None
    • Environment:
      Jenkins 2.89.4 on centOS 7.4, java 1.8.0_144, resource-disposer plugin 0.9
    • Similar Issues:

      Description

      resource-disposer plugin update from version 0.8 to version 0.9 causes jobs to fail when the job is being run concurrently, with errors:

      FATAL: Task java.util.concurrent.FutureTask@731dc390 rejected from java.util.concurrent.ThreadPoolExecutor@251a74c5[Running, pool size = 10, active threads = 10, queued tasks = 0, completed tasks = 1055]
      java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@731dc390 rejected from java.util.concurrent.ThreadPoolExecutor@251a74c5[Running, pool size = 10, active threads = 10, queued tasks = 0, completed tasks = 1055]
             at java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(Unknown Source)
             at java.util.concurrent.ThreadPoolExecutor.reject(Unknown Source)
             at java.util.concurrent.ThreadPoolExecutor.execute(Unknown Source)
             at java.util.concurrent.AbstractExecutorService.submit(Unknown Source)
             at com.google.common.util.concurrent.ForwardingExecutorService.submit(ForwardingExecutorService.java:110)
             at jenkins.util.InterceptingExecutorService.submit(InterceptingExecutorService.java:49)
             at org.jenkinsci.plugins.resourcedisposer.AsyncResourceDisposer.dispose(AsyncResourceDisposer.java:146)
      

      The issue is gone after downgrading resource-disposer plugin to 0.8 version

      Please find attached config.xml with the job configuration on which I observed the issue, too.

        Attachments

          Activity

          olivergondza Oliver Gondža added a comment -

          Omission on my side. I am releasing 0.10 with the throttling support reverted to reduce the impact. Proper fix to be implemented later.

          olivergondza Oliver Gondža added a comment -

          Fixed by https://github.com/jenkinsci/resource-disposer-plugin/commit/9ef6aec9d6e7162e71c0b8303db1776dc1bd6c22 to be released in 0.11. Thanks for reporting the problem.

          thenry145 Wojciech Sz added a comment -

          Great, thanks for such quick response and fix. 


            People

            Assignee:
            olivergondza Oliver Gondža
            Reporter:
            thenry145 Wojciech Sz
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: