Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52180

please help me to install

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Not A Defect
    • Component/s: _unsorted
    • Labels:
      None
    • Similar Issues:

      Description

      C:\>cd C:\Program Files (x86)\Jenkins C:\Program Files (x86)\Jenkins>java -jar jenkins.war Running from: C:\Program Files (x86)\Jenkins\jenkins.war webroot: $user.home/.jenkins Jun 26, 2018 3:49:52 PM org.eclipse.jetty.util.log.Log initialized INFO: Logging initialized @789ms to org.eclipse.jetty.util.log.JavaUtilLog Jun 26, 2018 3:49:52 PM winstone.Logger logInternal INFO: Beginning extraction from war file ←[33mJun 26, 2018 3:50:12 PM org.eclipse.jetty.server.handler.ContextHandler set ContextPath WARNING: Empty contextPath ←[0mJun 26, 2018 3:50:12 PM org.eclipse.jetty.server.Server doStart INFO: jetty-9.4.z-SNAPSHOT, build timestamp: 2017-11-22T02:57:37+05:30, git hash : 82b8fb23f757335bb3329d540ce37a2a2615f0a8 Jun 26, 2018 3:50:13 PM org.eclipse.jetty.webapp.StandardDescriptorProcessor vis itServlet INFO: NO JSP Support for /, did not find org.eclipse.jetty.jsp.JettyJspServlet Jun 26, 2018 3:50:13 PM org.eclipse.jetty.server.session.DefaultSessionIdManager doStart INFO: DefaultSessionIdManager workerName=node0 Jun 26, 2018 3:50:13 PM org.eclipse.jetty.server.session.DefaultSessionIdManager doStart INFO: No SessionScavenger set, using defaults Jun 26, 2018 3:50:13 PM org.eclipse.jetty.server.session.HouseKeeper startScaven ging INFO: Scavenging every 660000ms Jenkins home directory: C:\Users\GRPATIL\.jenkins found at: $user.home/.jenkins Jun 26, 2018 3:50:14 PM org.eclipse.jetty.server.handler.ContextHandler doStart INFO: Started w.@32232e55\{/,file:///C:/Users/GRPATIL/.jenkins/war/,AVAILABLE}{C: \Users\GRPATIL\.jenkins\war} Jun 26, 2018 3:50:14 PM org.eclipse.jetty.server.AbstractConnector doStop INFO: Stopped ServerConnector@33617539\{HTTP/1.1,[http/1.1]}{0.0.0.0:8080} Jun 26, 2018 3:50:14 PM org.eclipse.jetty.server.session.HouseKeeper stopScaveng ing INFO: Stopped scavenging Jun 26, 2018 3:50:14 PM hudson.WebAppMain contextDestroyed INFO: Shutting down a Jenkins instance that was still starting up java.lang.Throwable: reason at hudson.WebAppMain.contextDestroyed(WebAppMain.java:388) at org.eclipse.jetty.server.handler.ContextHandler.callContextDestroyed( ContextHandler.java:898) at org.eclipse.jetty.servlet.ServletContextHandler.callContextDestroyed( ServletContextHandler.java:545) at org.eclipse.jetty.server.handler.ContextHandler.stopContext(ContextHa ndler.java:873) at org.eclipse.jetty.servlet.ServletContextHandler.stopContext(ServletCo ntextHandler.java:355) at org.eclipse.jetty.webapp.WebAppContext.stopWebapp(WebAppContext.java: 1521) at org.eclipse.jetty.webapp.WebAppContext.stopContext(WebAppContext.java :1485) at org.eclipse.jetty.server.handler.ContextHandler.doStop(ContextHandler .java:927) at org.eclipse.jetty.servlet.ServletContextHandler.doStop(ServletContext Handler.java:271) at org.eclipse.jetty.webapp.WebAppContext.doStop(WebAppContext.java:569) at org.eclipse.jetty.util.component.AbstractLifeCycle.stop(AbstractLifeC ycle.java:89) at org.eclipse.jetty.util.component.ContainerLifeCycle.stop(ContainerLif eCycle.java:144) at org.eclipse.jetty.util.component.ContainerLifeCycle.doStop(ContainerL ifeCycle.java:162) at org.eclipse.jetty.server.handler.AbstractHandler.doStop(AbstractHandl er.java:124) at org.eclipse.jetty.server.Server.doStop(Server.java:489) at org.eclipse.jetty.util.component.AbstractLifeCycle.stop(AbstractLifeC ycle.java:89) at winstone.Launcher.shutdown(Launcher.java:307) at winstone.Launcher.<init>(Launcher.java:167) at winstone.Launcher.main(Launcher.java:354) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at Main._main(Main.java:312) at Main.main(Main.java:136) Exception in thread "Jenkins initialization thread" Jun 26, 2018 3:50:14 PM org. eclipse.jetty.server.handler.ContextHandler doStop INFO: Stopped w.@32232e55\{/,null,UNAVAILABLE}{C:\Users\GRPATIL\.jenkins\war} java.lang.NoClassDefFoundError: hudson/util/HudsonFailedToLoad at hudson.WebAppMain$3.run(WebAppMain.java:247) Caused by: java.lang.ClassNotFoundException: hudson.util.HudsonFailedToLoad at java.net.URLClassLoader$1.run(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at org.eclipse.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoade r.java:565) at java.lang.ClassLoader.loadClass(Unknown Source) ... 1 more Jun 26, 2018 3:50:14 PM winstone.Logger logInternal INFO: Jetty shutdown successfully java.io.IOException: Failed to start Jetty at winstone.Launcher.<init>(Launcher.java:156) at winstone.Launcher.main(Launcher.java:354) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at Main._main(Main.java:312) at Main.main(Main.java:136) Caused by: java.net.BindException: Address already in use: bind at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) at org.eclipse.jetty.server.ServerConnector.openAcceptChannel(ServerConn ector.java:334) at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:30 2) at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNet workConnector.java:80) at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java :238) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLife Cycle.java:68) at org.eclipse.jetty.server.Server.doStart(Server.java:397) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLife Cycle.java:68) at winstone.Launcher.<init>(Launcher.java:154) ... 7 more ←[31mJun 26, 2018 3:50:14 PM winstone.Logger logInternal SEVERE: Container startup failed java.io.IOException: Failed to start Jetty at winstone.Launcher.<init>(Launcher.java:156) at winstone.Launcher.main(Launcher.java:354) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at Main._main(Main.java:312) at Main.main(Main.java:136) Caused by: java.net.BindException: Address already in use: bind at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) at org.eclipse.jetty.server.ServerConnector.openAcceptChannel(ServerConn ector.java:334) at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:30 2) at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNet workConnector.java:80) at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java :238) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLife Cycle.java:68) at org.eclipse.jetty.server.Server.doStart(Server.java:397) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLife Cycle.java:68) at winstone.Launcher.<init>(Launcher.java:154) ... 7 more ←[0m
      

        Attachments

          Activity

          oleg_nenashev Oleg Nenashev added a comment -

          From what I see the port is already in use:

          ava.net.BindException: Address already in use: bind at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) at org.eclipse.jetty.server.ServerConnector.openAcceptChannel(ServerConn ector.java:334) at 
          

          Make sure you do not have other services running on the port

          gunderao Gunderao Patil added a comment -

          Thank you so much....i have installed but i got new problem...please check once

           

          This site can’t be reached

          localhost refused to connect.
           

          oleg_nenashev Oleg Nenashev added a comment -

          Cannot be diagnosed.
          Please follow guidelines in https://wiki.jenkins.io/display/JENKINS/How+to+report+an+issue

          gunderao Gunderao Patil added a comment -

          after executing build im getting this error please look into this
          java.nio.file.FileSystemException: G:\JAVA: The device is not ready.

          at sun.nio.fs.WindowsException.translateToIOException(Unknown Source)
          at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
          at sun.nio.fs.WindowsException.rethrowAsIOException(Unknown Source)
          at sun.nio.fs.WindowsFileSystemProvider.checkReadAccess(Unknown Source)
          at sun.nio.fs.WindowsFileSystemProvider.checkAccess(Unknown Source)
          at java.nio.file.Files.createDirectories(Unknown Source)
          at hudson.FilePath.mkdirs(FilePath.java:3103)
          at hudson.FilePath.access$900(FilePath.java:209)
          at hudson.FilePath$Mkdirs.invoke(FilePath.java:1221)
          at hudson.FilePath$Mkdirs.invoke(FilePath.java:1217)
          at hudson.FilePath.act(FilePath.java:1047)
          at hudson.FilePath.act(FilePath.java:1025)
          at hudson.FilePath.mkdirs(FilePath.java:1213)
          at hudson.model.AbstractProject.checkout(AbstractProject.java:1202)
          at hudson.model.AbstractBuild$AbstractBuildExecution.defaultCheckout(AbstractBuild.java:574)
          at jenkins.scm.SCMCheckoutStrategy.checkout(SCMCheckoutStrategy.java:86)
          at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:499)
          at hudson.model.Run.execute(Run.java:1794)
          at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
          at hudson.model.ResourceController.execute(ResourceController.java:97)
          at hudson.model.Executor.run(Executor.java:429)
          Finished: FAILURE
           

          gunderao Gunderao Patil added a comment -

          I have installed Jenkins but i forgot username and password and also i changed the port number so how can i reset user name and password. Jenkins version is 2.128
          Tried to check the Jenkins folder to find admin username and password but not find.

          oleg_nenashev Oleg Nenashev added a comment -

          Closing as Not a Defect since there is no defect report in this ticket


            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            gunderao Gunderao Patil
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: