Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52184

Secrets cannot be read with pipeline utils

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Critical
    • Resolution: Duplicate
    • Component/s: kubernetes-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.121.1
      Kubernetes-plugin 1.8.4
      jdk 8
    • Similar Issues:

      Description

      Hello,

      I use kubernetes secrets to configure my CI containers. I updated updating from 1.5.1 to 1.8.4. Unfortunately fileExists and readYaml form jenkins pipeline utils are not able to read the mounted secrets anymore. I can list the folder /secrets and do a cat on /secrets/mysecret but fileExists /secrets/mysecret => false and readYaml /secrets/mysecret  throws file not found exception.

       

      The only thing I changed is the plugin version. I run on kubernetes 1.10.X

       

      I hope I provided all necessary information (I stripped few things of versions i deem unnecessary)

       

      Regards

        Attachments

          Issue Links

            Activity

            csanchez Carlos Sanchez added a comment -

            looks like a duplicate of JENKINS-50879


              People

              Assignee:
              csanchez Carlos Sanchez
              Reporter:
              jonashartwig Jonas Hartwig
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: