Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52229

'perl' is not recognized as an internal or external command,operable program or batch file.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Blocker
    • Resolution: Not A Defect
    • Component/s: core
    • Labels:
      None
    • Similar Issues:

      Description

      I have provided the path for the perl script and the command to compile and test the android project which I used to do manually

      in Execute Windows batch command

      pushd \\LAB498\Dropbox\CTA_SANITY_NEW_RELEASE
      perl unit_fta_test_all_cmds_pass.pl

      I am trying to run the perl script to test my android application but I am getting error like

      'perl' is not recognized as an internal or external command,
      operable program or batch file.

      Log from console output:

      Started by user Swetha
      Building in workspace C:\Program Files (x86)\Jenkins\workspace\Sample
       > C:\Program Files\Git\cmd\git.exe rev-parse --is-inside-work-tree # timeout=10
      Fetching changes from the remote Git repository
       > C:\Program Files\Git\cmd\git.exe config remote.origin.url https://github.qualcomm.com/ProdTools/CTA.git # timeout=10
      Fetching upstream changes from https://github.qualcomm.com/ProdTools/CTA.git
       > C:\Program Files\Git\cmd\git.exe --version # timeout=10
      using GIT_ASKPASS to set credentials
       > C:\Program Files\Git\cmd\git.exe fetch --tags --progress https://github.qualcomm.com/ProdTools/CTA.git +refs/heads/:refs/remotes/origin/
       > C:\Program Files\Git\cmd\git.exe rev-parse "refs/remotes/origin/master^{commit}" # timeout=10
       > C:\Program Files\Git\cmd\git.exe rev-parse "refs/remotes/origin/origin/master^{commit}" # timeout=10
      Checking out Revision 2a66e89fd8de33830f939e97582169316ff204a1 (refs/remotes/origin/master)
       > C:\Program Files\Git\cmd\git.exe config core.sparsecheckout # timeout=10
       > C:\Program Files\Git\cmd\git.exe checkout -f 2a66e89fd8de33830f939e97582169316ff204a1
      Commit message: "code cleanup removing extra debug msgs and some parts of unused code"
       > C:\Program Files\Git\cmd\git.exe rev-list --no-walk 2a66e89fd8de33830f939e97582169316ff204a1 # timeout=10
      [Sample] $ cmd /c call C:\WINDOWS\TEMP\jenkins8424052614343846572.bat

      C:\Program Files (x86)\Jenkins\workspace\Sample>pushd \\LAB498\Dropbox\CTA_SANITY_NEW_RELEASE

      Z:\CTA_SANITY_NEW_RELEASE>perl unit_fta_test_all_cmds_pass.pl 
      'perl' is not recognized as an internal or external command,
      operable program or batch file.

      Z:\CTA_SANITY_NEW_RELEASE>exit 9009
      Build step 'Execute Windows batch command' marked build as failure
      Finished: FAILURE

        Attachments

          Activity

          danielbeck Daniel Beck added a comment -

          This is not a bug in Jenkins. perl is not on the Path of your script, this is only a configuration issue on your side.


            People

            Assignee:
            0000144223 Erina Gomi
            Reporter:
            c_shuded swetha huded
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: