Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-52912

Max connections to Kubernetes API fails to validate with "This URL requires POST"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Component/s: kubernetes-plugin
    • Labels:
      None
    • Environment:
      Jenkins 2.107.3 installed on kubernetes cluster
    • Similar Issues:
    • Released As:
      1.13.7

      Description

       
      I am running jenkins 2.107.3 on a kubernetes cluster. In the

      "Manage jenkins" -> "Configure system" , in the cloud section the "Max connections to Kubernetes API" is set to the default 32.

      But i am getting error in here and the jenkins is not getting connected to my kubernetes without authentication.

      The error says

        Attachments

          Activity

          csanchez Carlos Sanchez added a comment -

          The error is displayed in the config page but the changes can be saved anyway

          vidyas16 Vidya Subramanyam added a comment -

          Yes the changes can be saved. But this jenkins is running on a kubernetes cluster and the automatic authentication is failing. I have to do a client configuration on my jenkins system to use any kubectl command. Can you please tell me, what this error means and how to get rid of this??

          vidyas16 Vidya Subramanyam added a comment -

          Looks like this is caused by the kubernetes plugin. The version of my kubernetes plugin is 1.12.2. Also downgraded it to 1.10.1 but of no use.

          sharkannon Stephen Herd added a comment -

          Seeing this issue as well, 

          Jenkins 2.121.2 (LTS)

          Kubernetes Plugin: 1.10.1+, 1.12.x (Upgraded and downgraded to no avail)

          Kubernetes: 1.10.5 (on GKE)

          NGINX: 1.15.2 (SSL Proxy in front of Jenkins

          vlatombe Vincent Latombe added a comment -

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            vidyas16 Vidya Subramanyam
            Votes:
            1 Vote for this issue
            Watchers:
            8 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: