Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-53994

Parameters that use own descriptor to check/fill fields returns 404 in schedule release page

    XMLWordPrintable

Details

    • New Feature
    • Status: Resolved (View Workflow)
    • Major
    • Resolution: Fixed
    • release-plugin
    • None
    • Jenkins 2.121.3
      release-plugin 2.10.1
    • Release plugin 2.10.2

    Description

      If I define a new parameters like validation string parameter that use a regex to validate the user input it performs a doCheckXYZ method of its descriptor. In the Schedule Release Page (action page) the HTTP request returns 404 because the URL is relative to the action page $JENKINS_URL/jobs/XYZ/release instead of the project.

      Attachments

        Activity

          nfalco Nikolas Falco added a comment - - edited

          oleg_nenashev I know that you had mark yourself as retired developer of this plugin (and you are usually busy) but the solution is really fast and already proposed here

          nfalco Nikolas Falco added a comment - - edited oleg_nenashev I know that you had mark yourself as retired developer of this plugin (and you are usually busy) but the solution is really fast and already proposed here
          oleg_nenashev Oleg Nenashev added a comment -

          I am still happy to review/release PRs when there is low risk of regressions

          oleg_nenashev Oleg Nenashev added a comment - I am still happy to review/release PRs when there is low risk of regressions

          People

            nfalco Nikolas Falco
            nfalco Nikolas Falco
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: