Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56579

.mvn/extensions.xml not recognized

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Cannot Reproduce
    • Component/s: maven-invoker-plugin
    • Labels:
      None
    • Environment:
      jenkins 2.164.1
      maven-invoker-plugin 2.4

      ubuntu 18.04.2 master
      windows 7 slaves
    • Similar Issues:

      Description

      We wanted to setup a tycho-pomless build on jenkins, with maven 3.6.0. Running the build without Jenkins works fine.

      The pom.xml is in a subfolder next to the .mvn/extensions.xml

      This job only works when the pom.xml is in the workspace root and maven 3.3.9 is used. Useing dir() in a pipeline when calling maven 3.3.9 is working too.

       

      We could reproduce this issue with the tycho-example form here too https://github.com/vogellacompany/tycho-example

      3.3.9 + code in "sub"

      [Vogella] $ cmd.exe /C "c:\jenkins\tools\hudson.tasks.Maven_MavenInstallation\3.3.9\bin\mvn.cmd clean verify -V -B --file sub/pom.xml && exit %%ERRORLEVEL%%"
      Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T17:41:47+01:00)
      Maven home: c:\jenkins\tools\hudson.tasks.Maven_MavenInstallation\3.3.9
      Java version: 1.8.0_202, vendor: Oracle Corporation
      Java home: c:\jenkins\tools\hudson.model.JDK\8\jre
      Default locale: en_US, platform encoding: Cp1252
      OS name: "windows 7", version: "6.1", arch: "amd64", family: "dos"
      [INFO] Scanning for projects...
      [ERROR] [ERROR] Some problems were encountered while processing the POMs:
      [ERROR] Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.logging.config\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist @ 
      [ERROR] Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.tycho.plugin1\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist @ 
      [ERROR] Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.tycho.rcp\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist @ 
      [ERROR] Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.tycho.p2.ui\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist @ 
      [ERROR] Child module C:\jenkins\workspace\Vogella\sub\features\com.vogella.tycho.feature\pom.xml of C:\jenkins\workspace\Vogella\sub\features\pom.xml does not exist @ 
      [ERROR] Child module C:\jenkins\workspace\Vogella\sub\tests\com.vogella.tycho.plugin1.tests\pom.xml of C:\jenkins\workspace\Vogella\sub\tests\pom.xml does not exist @ 
      [ERROR] Child module C:\jenkins\workspace\Vogella\sub\tests\com.vogella.tycho.rcp.tests\pom.xml of C:\jenkins\workspace\Vogella\sub\tests\pom.xml does not exist @ 
       @ 
      [ERROR] The build could not read 3 projects -> [Help 1]
      [ERROR]   
      [ERROR]   The project com.vogella.tycho:com.vogella.tycho.bundles:1.0.0-SNAPSHOT (C:\jenkins\workspace\Vogella\sub\bundles\pom.xml) has 4 errors
      [ERROR]     Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.logging.config\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist
      [ERROR]     Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.tycho.plugin1\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist
      [ERROR]     Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.tycho.rcp\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist
      [ERROR]     Child module C:\jenkins\workspace\Vogella\sub\bundles\com.vogella.tycho.p2.ui\pom.xml of C:\jenkins\workspace\Vogella\sub\bundles\pom.xml does not exist
      [ERROR]   
      [ERROR]   The project com.vogella.tycho:com.vogella.tycho.features:1.0.0-SNAPSHOT (C:\jenkins\workspace\Vogella\sub\features\pom.xml) has 1 error
      [ERROR]     Child module C:\jenkins\workspace\Vogella\sub\features\com.vogella.tycho.feature\pom.xml of C:\jenkins\workspace\Vogella\sub\features\pom.xml does not exist
      [ERROR]   
      [ERROR]   The project com.vogella.tycho:com.vogella.tycho.tests:1.0.0-SNAPSHOT (C:\jenkins\workspace\Vogella\sub\tests\pom.xml) has 2 errors
      [ERROR]     Child module C:\jenkins\workspace\Vogella\sub\tests\com.vogella.tycho.plugin1.tests\pom.xml of C:\jenkins\workspace\Vogella\sub\tests\pom.xml does not exist
      [ERROR]     Child module C:\jenkins\workspace\Vogella\sub\tests\com.vogella.tycho.rcp.tests\pom.xml of C:\jenkins\workspace\Vogella\sub\tests\pom.xml does not exist
      [ERROR] 
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR] 
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
      Build step 'Invoke top-level Maven targets' marked build as failure
      Finished: FAILURE
      

      3.6.0 and code in root

      [Vogella] $ cmd.exe /C "c:\jenkins\tools\hudson.tasks.Maven_MavenInstallation\3.6.0\bin\mvn.cmd clean verify -V -B && exit %%ERRORLEVEL%%"
      Apache Maven 3.6.0 (97c98ec64a1fdfee7767ce5ffb20918da4f719f3; 2018-10-24T20:41:47+02:00)
      Maven home: c:\jenkins\tools\hudson.tasks.Maven_MavenInstallation\3.6.0\bin\..
      Java version: 1.8.0_202, vendor: Oracle Corporation, runtime: c:\jenkins\tools\hudson.model.JDK\8\jre
      Default locale: en_US, platform encoding: Cp1252
      OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"
      [INFO] Scanning for projects...
      [ERROR] [ERROR] Some problems were encountered while processing the POMs:
      [FATAL] Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10
      [FATAL] Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10
      [FATAL] Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10
      [FATAL] Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10
       @ 
      [ERROR] The build could not read 4 projects -> [Help 1]
      [ERROR]   
      [ERROR]   The project com.vogella.tycho:com.vogella.tycho.bundles:1.0.0-SNAPSHOT (C:\jenkins\workspace\Vogella\bundles\pom.xml) has 1 error
      [ERROR]     Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10 -> [Help 2]
      [ERROR]   
      [ERROR]   The project com.vogella.tycho:com.vogella.tycho.features:1.0.0-SNAPSHOT (C:\jenkins\workspace\Vogella\features\pom.xml) has 1 error
      [ERROR]     Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10 -> [Help 2]
      [ERROR]   
      [ERROR]   The project com.vogella.tycho:com.vogella.tycho.tests:1.0.0-SNAPSHOT (C:\jenkins\workspace\Vogella\tests\pom.xml) has 1 error
      [ERROR]     Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10 -> [Help 2]
      [ERROR]   
      [ERROR]   The project com.vogella.tycho:com.vogella.tycho.releng:1.0.0-SNAPSHOT (C:\jenkins\workspace\Vogella\releng\pom.xml) has 1 error
      [ERROR]     Non-resolvable parent POM for com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT: Could not find artifact com.vogella.tycho:com.vogella.tycho.configuration:pom:1.0.0-SNAPSHOT and 'parent.relativePath' points at wrong local POM @ com.vogella.tycho:com.vogella.tycho.root:1.0.0-SNAPSHOT, C:\jenkins\workspace\Vogella\pom.xml, line 7, column 10 -> [Help 2]
      [ERROR] 
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR] 
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
      [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
      Build step 'Invoke top-level Maven targets' marked build as failureFinished: FAILURE
      

        Attachments

          Activity

          benbrummer Benjamin Brummer added a comment - - edited
          • Building on the jenkins linux master works with maven 3.6.0 with and without pom.xml in subdirectory.
          • Windows 10 Agent fails
          • Ubuntu agent is fine

          So looks like a Windows problem.

          benbuescher Benjamin Büscher added a comment -

          I think I ran into the same issue but from a slightly different direction. I also have a pomless tycho build running on Windows slaves.

          • I call maven via CMD, not the jenkins maven plugin. (-> I dont think its a jenkins issue)
            • This build fails on maven 3.6.0 with similar looking log and works on maven 3.3.9, just as described here.
          • I've set up a local jenkins on my dev machine (win10) - this build works fine using maven 3.6.0!

          My guess is that this is a maven issue on win server, probably related to how plugins like tycho are loaded. 

          benbrummer Benjamin Brummer added a comment -

          "I call maven via CMD, not the jenkins maven plugin" => Without jenkins involved at all? Without jenkins it works here with 3.6.0.

          Useing a Jenkins agent => No matter how we call mvn, it fails.

          benbuescher Benjamin Büscher added a comment -

          It's a little ugly: jenkins -> ant -> cmd -> maven:

          Jenkins calls an ant build via ant plugin. Inside of the ant build an exec target is used to call cmd launching the maven build.

          benbrummer Benjamin Brummer added a comment -

          I can not reproduce the problem anymore. All maven versions work now as expected.


            People

            Assignee:
            olamy Olivier Lamy
            Reporter:
            benbrummer Benjamin Brummer
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: