Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-56662

BlueOcean fails to complete loading

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Not A Defect
    • blueocean-plugin
    • None
    • Jenkins 2.303
      BlueOcean 1.25.1

    Description

      After starting Jenkins, and clicking the "Open Blue Ocean" the progress bar gets stuck at appr 85%.  Submitted new bug here as requested by halkeye. The Java console shows a number of errors, eg:

      "Error initializing Jenkins JavaScript bundle "blueocean-core-js" Error: Unexpected error executing startup module "../tstemp/js/bundleStartup.js": Error: Must call ExtensionStore.init"

       Log is attached as blueocean_stuck_20190321.log

       

       

      Attachments

        Activity

          halkeye Gavin Mogan added a comment -

          "it doesn't work" is always frustrating from the other side. especially with no logs or anything.

          In the past when blueocean doesn't load up, its because its missing a depending module. Like for example, blueocean-web might be installed, but not blueocean-config. This is usually caused by the "Blueocean" meta package not being installed.

          Are there any blueocean plugins not installed?

          halkeye Gavin Mogan added a comment - "it doesn't work" is always frustrating from the other side. especially with no logs or anything. In the past when blueocean doesn't load up, its because its missing a depending module. Like for example, blueocean-web might be installed, but not blueocean-config. This is usually caused by the "Blueocean" meta package not being installed. Are there any blueocean plugins not installed?
          mray m ray added a comment -

          Thanks! That must have been the issue. I added a few more "Blue Ocean" related plugins from the plugin manager and after restart Blue Ocean is working (no hangs). Thanks for this suggestion, though I'm not sure what's the minimal set of Blue Ocean plugins I  needed.

          mray m ray added a comment - Thanks! That must have been the issue. I added a few more "Blue Ocean" related plugins from the plugin manager and after restart Blue Ocean is working (no hangs). Thanks for this suggestion, though I'm not sure what's the minimal set of Blue Ocean plugins I  needed.
          halkeye Gavin Mogan added a comment -

          If you want an easy first time pr,

           

          https://github.com/jenkinsci/blueocean-plugin/blob/master/blueocean/src/main/resources/index.jelly

          Can get updated to make it more clear on the plugins page

           

          halkeye Gavin Mogan added a comment - If you want an easy first time pr,   https://github.com/jenkinsci/blueocean-plugin/blob/master/blueocean/src/main/resources/index.jelly Can get updated to make it more clear on the plugins page  
          monger39 David Riemens added a comment -

          halkeye :I think this issue can be closed. For it is now working properly after having updated Jenkins and the BlueOcean plugins. Also  mray commented that it works.

          monger39 David Riemens added a comment - halkeye :I think this issue can be closed. For it is now working properly after having updated Jenkins and the BlueOcean plugins. Also   mray commented that it works.
          halkeye Gavin Mogan added a comment -

          Happy to close any ticket

          halkeye Gavin Mogan added a comment - Happy to close any ticket

          People

            monger39 David Riemens
            monger39 David Riemens
            Votes:
            2 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: