Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-5968

org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes

    XMLWordPrintable

Details

    • Bug
    • Status: Reopened (View Workflow)
    • Major
    • Resolution: Unresolved
    • backup-plugin
    • None
    • RHEL 64 bit

    Description

      Hudson version: 1.348
      Hudson executed via: nohup $JAVA -Dhudson.model.Run.ArtifactList.listCutoff=24 -jar $HUDSON_WAR --httpPort=8008 >$HUDSON_LOG 2>&1 &
      Backup plugin version: 1.4.1

      [ INFO] Backup started at [03/17/10 12:08:43]
      [ INFO] Setting hudson in shutdown mode to avoid files corruptions.
      [ INFO] Waiting all jobs end...
      [ INFO] Number of running jobs detected : 0
      [ INFO] All jobs finished.
      [ INFO] Full backup file name : /home/tk694h/hudson/backup_20100317_1208.zip
      [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /home/tk694h/.hudson/jobs/AS-10.3-Tibco-ActivityLog/scm-polling.log
      org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add jobs/AS-10.3-Tibco-ActivityLog/scm-polling.log
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
      at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:125)
      at java.lang.Thread.run(Thread.java:619)
      Caused by: java.io.IOException: Unable to add jobs/AS-10.3-Tibco-ActivityLog/scm-polling.log
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
      at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335)
      at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
      ... 2 more
      [ INFO] Cancel hudson shutdown mode
      [ INFO] Backup end at [03/17/10 12:08:48]
      [ INFO] [5.004s]

      Attachments

        Issue Links

          Activity

            tk694h tk694h added a comment -

            I should have also mentioned that the scm-polling.log file does exist and is readable.

            tk694h tk694h added a comment - I should have also mentioned that the scm-polling.log file does exist and is readable.
            dougborg Doug Borg added a comment -

            It looks like this issue has already been (partially) resolved upstream:

            http://jira.codehaus.org/browse/PLXCOMP-138

            Does the backup plugin use the latest Plexus component? If I understand the issue above, using an updated version with the patch mentioned in the bug above might help us debug the actual cause of this error.

            dougborg Doug Borg added a comment - It looks like this issue has already been (partially) resolved upstream: http://jira.codehaus.org/browse/PLXCOMP-138 Does the backup plugin use the latest Plexus component? If I understand the issue above, using an updated version with the patch mentioned in the bug above might help us debug the actual cause of this error.

            This seems quite random. I have the backup 1.6 plugin and here is what happens. I am using the "backup configurations only" option and not shutting down Hudson (because it takes too long!). There is no apparent reason why it fails on the listed config.xml - it is stable and not being changed.

            .. (many succesfully accessed config files) ..
            [DEBUG] jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-eca/config.xml file
            [DEBUG] jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$CommonCC/config.xml file
            [DEBUG] jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml file
            [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /opt/hudson/conf/jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml
            org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
            at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:130)
            at java.lang.Thread.run(Thread.java:619)
            Caused by: java.io.IOException: Unable to add jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335)
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
            ... 2 more
            [ INFO] Cancel hudson shutdown mode

            steventheamusing StevenTheAmusing added a comment - This seems quite random. I have the backup 1.6 plugin and here is what happens. I am using the "backup configurations only" option and not shutting down Hudson (because it takes too long!). There is no apparent reason why it fails on the listed config.xml - it is stable and not being changed. .. (many succesfully accessed config files) .. [DEBUG] jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-eca/config.xml file [DEBUG] jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$CommonCC/config.xml file [DEBUG] jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml file [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /opt/hudson/conf/jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115) at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:130) at java.lang.Thread.run(Thread.java:619) Caused by: java.io.IOException: Unable to add jobs/CTX_Nightly_Smoke_Tests_Prepare_Build/modules/com.cisco.txbu.ctc$ctc-admin/config.xml at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335) at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113) ... 2 more [ INFO] Cancel hudson shutdown mode
            rseguy Romain Seguy added a comment -

            Upgraded to Plexus Archive 1.2

            rseguy Romain Seguy added a comment - Upgraded to Plexus Archive 1.2

            Code changed in jenkins
            User: rseguy
            Path:
            .gitignore
            README.md
            pom.xml
            src/main/resources/org/jvnet/hudson/plugins/backup/Messages.properties
            src/main/resources/org/jvnet/hudson/plugins/backup/Messages_fr.properties
            http://jenkins-ci.org/commit/backup-plugin/8f4fef575413b8b4de8f4966fd93644a521c4378
            Log:
            Fixed JENKINS-5968

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: rseguy Path: .gitignore README.md pom.xml src/main/resources/org/jvnet/hudson/plugins/backup/Messages.properties src/main/resources/org/jvnet/hudson/plugins/backup/Messages_fr.properties http://jenkins-ci.org/commit/backup-plugin/8f4fef575413b8b4de8f4966fd93644a521c4378 Log: Fixed JENKINS-5968

            Code changed in jenkins
            User: rseguy
            Path:
            .gitignore
            README.md
            pom.xml
            src/main/resources/org/jvnet/hudson/plugins/backup/Messages.properties
            src/main/resources/org/jvnet/hudson/plugins/backup/Messages_fr.properties
            http://jenkins-ci.org/commit/backup-plugin/8f4fef575413b8b4de8f4966fd93644a521c4378
            Log:
            Fixed JENKINS-5968

            scm_issue_link SCM/JIRA link daemon added a comment - Code changed in jenkins User: rseguy Path: .gitignore README.md pom.xml src/main/resources/org/jvnet/hudson/plugins/backup/Messages.properties src/main/resources/org/jvnet/hudson/plugins/backup/Messages_fr.properties http://jenkins-ci.org/commit/backup-plugin/8f4fef575413b8b4de8f4966fd93644a521c4378 Log: Fixed JENKINS-5968
            bprodoehl Brian Prodoehl added a comment - - edited

            Hudson version: 1.436
            Backup plugin version: 1.6.1

            Running a backup with no additional Backup content selected.

            [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /var/lib/jenkins/jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt
            org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115)
            at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:130)
            at java.lang.Thread.run(Thread.java:636)
            Caused by: java.io.IOException: Unable to add jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364)
            at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335)
            at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113)
            ... 2 more

            That file is readable:
            [jenkins@jenkins ~]$ ls -la /var/lib/jenkins/jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt
            rw - r - - r - - 1 jenkins jenkins 94 Nov 4 00:03 /var/lib/jenkins/jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt
            [jenkins@jenkins ~]$

            bprodoehl Brian Prodoehl added a comment - - edited Hudson version: 1.436 Backup plugin version: 1.6.1 Running a backup with no additional Backup content selected. [ERROR] org.codehaus.plexus.archiver.ArchiverException: Failed to read filesystem attributes for: /var/lib/jenkins/jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt org.jvnet.hudson.plugins.backup.BackupException: java.io.IOException: Unable to add jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:115) at org.jvnet.hudson.plugins.backup.utils.BackupTask.run(BackupTask.java:130) at java.lang.Thread.run(Thread.java:636) Caused by: java.io.IOException: Unable to add jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt at org.jvnet.hudson.plugins.backup.utils.BackupEngine.handleFile(BackupEngine.java:90) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:367) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:364) at org.apache.commons.io.DirectoryWalker.walk(DirectoryWalker.java:335) at org.jvnet.hudson.plugins.backup.utils.BackupEngine.doBackup(BackupEngine.java:113) ... 2 more That file is readable: [jenkins@jenkins ~] $ ls -la /var/lib/jenkins/jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt rw - r - - r - - 1 jenkins jenkins 94 Nov 4 00:03 /var/lib/jenkins/jobs/switchboard-trunk-master/configurations/axis-Nodes/ubuntu1110/lastSuccessful/revision.txt [jenkins@jenkins ~] $
            rseguy Romain Seguy added a comment -

            Unassigning myself from this plugin, no time to work in it, sorry.

            rseguy Romain Seguy added a comment - Unassigning myself from this plugin, no time to work in it, sorry.

            People

              Unassigned Unassigned
              tk694h tk694h
              Votes:
              8 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated: