Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-63374

Bitbucket plugin changed API for the bitbucketPush trigger in an incompatible way

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • bitbucket-plugin
    • None
    • Jenkins 2.235.3
      Bitbucket plugin 1.1.19
    • 1.1.21

    Description

      After I updated Bitbucket plugin from 1.1.18 to 1.1.19 our builds ceased to work with the following message:
       
      "bitbucketPush" should have 1 arguments but has 0 arguments instead.
       
      Rolling back to 1.1.18 fixed the issue

      Attachments

        Activity

          bobf Bob Farrell added a comment - - edited

          tzach_solomon This Jenkinsfile recreates the error:

          pipeline {
            triggers {
              bitbucketPush()
            }
          
            agent {
              docker {
                image 'ubuntu'
              }
            }
          
            stages {
              stage('Example') {
                steps {
                  sh 'echo "Example"'
                }
              }
            }
          }
          

           

          bobf Bob Farrell added a comment - - edited tzach_solomon This Jenkinsfile recreates the error: pipeline { triggers { bitbucketPush() } agent { docker { image 'ubuntu' } } stages { stage( 'Example' ) { steps { sh 'echo "Example" ' } } } }  
          tzach_solomon Tzach Solomon added a comment -

          Reverted back to empty constructor and changed to use @DataBoundSetter.
          Should be fixed in 1.1.21

          tzach_solomon Tzach Solomon added a comment - Reverted back to empty constructor and changed to use @DataBoundSetter. Should be fixed in 1.1.21
          tzach_solomon Tzach Solomon added a comment -

          ganssauge thanks for reporting the problem and thanks all for the reproduction scenarios
          I was able to reproduce the problem and I think I fixed it, see version 1.1.21

          tzach_solomon Tzach Solomon added a comment - ganssauge thanks for reporting the problem and thanks all for the reproduction scenarios I was able to reproduce the problem and I think I fixed it, see version 1.1.21

          Thanks, tzach_solomon - for me it works again with 1.21.

          ganssauge Gottfried Ganßauge added a comment - Thanks, tzach_solomon - for me it works again with 1.21.
          tzach_solomon Tzach Solomon added a comment -

          Fixed

          tzach_solomon Tzach Solomon added a comment - Fixed

          People

            tzach_solomon Tzach Solomon
            ganssauge Gottfried Ganßauge
            Votes:
            3 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: