Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-717

missing image and files

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Won't Fix
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      findbugs 1.3
      http://bravo:8080/hudson/static/e1efa121/plugin/findbugs/icons/findbugs-48x48.gif
      On build view there is missing icon

      Also then you click on Findbigs trens image on project level there is exception:

      hudson/job/CERTIONE2_CORE/329/findbugsResult/

      javax.servlet.ServletException:
      file:/usr/local/hudson/plugins/findbugs/WEB-INF/classes/hudson/plugins/findbugs/FindBugsResult/index.jelly:5:57:
      <st:include> No page found 'sidepanel.jelly' for class
      hudson.plugins.findbugs.FindBugsResult
      org.kohsuke.stapler.jelly.JellyClassTearOff.serveIndexJelly(JellyClassTearOff.java:98)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:290)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:307)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:307)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:307)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:244)
      org.kohsuke.stapler.Stapler.service(Stapler.java:92)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      hudson.BasicAuthenticationFilter.doFilter(BasicAuthenticationFilter.java:79)

      root cause

      org.apache.commons.jelly.JellyTagException:
      file:/usr/local/hudson/plugins/findbugs/WEB-INF/classes/hudson/plugins/findbugs/FindBugsResult/index.jelly:5:57:
      <st:include> No page found 'sidepanel.jelly' for class
      hudson.plugins.findbugs.FindBugsResult
      org.kohsuke.stapler.jelly.IncludeTag.doTag(IncludeTag.java:71)
      org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
      org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      org.apache.commons.jelly.tags.define.InvokeBodyTag.doTag(InvokeBodyTag.java:91)
      org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
      org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
      org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
      org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
      org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
      org.apache.commons.jelly.impl.StaticTag.doTag(StaticTag.java:65)
      org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:112)
      org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
      org.apache.commons.jelly.tags.core.JellyTag.doTag(JellyTag.java:45)
      org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
      org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:80)
      org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
      org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:186)
      org.apache.commons.jelly.tags.core.JellyTag.doTag(JellyTag.java:45)
      org.apache.commons.jelly.impl.TagScript.run(TagScript.java:262)
      org.kohsuke.stapler.jelly.JellyClassTearOff.invokeScript(JellyClassTearOff.java:78)
      org.kohsuke.stapler.jelly.JellyClassTearOff.serveIndexJelly(JellyClassTearOff.java:93)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:290)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:307)
      org.kohsuke.stapler.MetaClass$15.dispatch(MetaClass.java:361)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:307)
      org.kohsuke.stapler.MetaClass$9.doDispatch(MetaClass.java:240)
      org.kohsuke.stapler.NameBasedDispatcher.dispatch(NameBasedDispatcher.java:30)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:307)
      org.kohsuke.stapler.Stapler.invoke(Stapler.java:244)
      org.kohsuke.stapler.Stapler.service(Stapler.java:92)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
      hudson.BasicAuthenticationFilter.doFilter(BasicAuthenticationFilter.java:79)

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          Would be nice if you could file one issue per request.

          The missing icon is already fixed in head, this is due to a change in hudson 1.127.

          drulli Ulli Hafner added a comment -

          Did the referenced build 329 run with findbugs 1.3? Or did you use different
          versions of the findbugs plugin for your saved builds? Maybe the serialized info
          has been changed during a release upgrade.

          I can't reproduce your error here on my installation.

          ramazanyich2 ramazanyich2 added a comment -

          my first run was with finsbugs 1.0 I think.
          And after that I upgraded to 1.3 and had this issue.

          drulli Ulli Hafner added a comment -

          Does the error still occur if you temporarily remove your the builds folder with
          your old builds?

          (I'm not sure if its worth to add code to support a version upgrade for old
          serialized builds.)

          ramazanyich2 ramazanyich2 added a comment -

          indeed after removing old builds (and cleaning browser cache) no error anymore


            People

            Assignee:
            drulli Ulli Hafner
            Reporter:
            ramazanyich2 ramazanyich2
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: