Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-7218

Base Clearcase : Tracking changes on a label

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • XP SP3

    Description

      We have a build job that uses a dynamic view with Config Spec:

      element * CHECKEDOUT
      element -directory * /main/LATEST
      element -file * 1T_READY

      The view and bulld job process only source code labeled "1T_READY".

      However when the job runs lshistory command (thus changes page) shows all the changed files since the last build job run regardless of their label.

      This leads to show wrong JIRA reports related that job. Also when the build fails, even the user didn't label his code as 1T_READY gets an e-nmail message as his code broke the build.

      Load rules in the configuration page did not have an option to include label type also. How can we manage to list changes only in build view?

      Kind regards

      Serkan ZENGIN

      Attachments

        Issue Links

          Activity

            This is definitely not a bug. The plugin can track changes on branches, not labels.

            And I know no way using Clearcase to retrieve the history of a label. Without this, we cannot do anything

            vlatombe Vincent Latombe added a comment - This is definitely not a bug. The plugin can track changes on branches, not labels. And I know no way using Clearcase to retrieve the history of a label. Without this, we cannot do anything

            This could be done with lshistory, when adding -minor switch to current lshistory call. It would then output operations with "mklabel" as operation kind (%o formatter). There could be an option to check for labels and/or branches, depending on what has been specified.

            I would make use of such option as well

            raspy Krzysztof Malinowski added a comment - This could be done with lshistory, when adding -minor switch to current lshistory call. It would then output operations with "mklabel" as operation kind (%o formatter). There could be an option to check for labels and/or branches, depending on what has been specified. I would make use of such option as well
            serk1979 serk1979 added a comment -

            Hello Raspy,

            It would be good to have such an option. Otherwise we will have to make a branch and merge the labeled version to that branch by an automated script. However that makes all the changes in changes page to be made by script's executor acount.

            Kind regards

            serk1979 serk1979 added a comment - Hello Raspy, It would be good to have such an option. Otherwise we will have to make a branch and merge the labeled version to that branch by an automated script. However that makes all the changes in changes page to be made by script's executor acount. Kind regards

            Implementation available in trunk.

            raspy Krzysztof Malinowski added a comment - Implementation available in trunk.
            josesa Jose Sa added a comment -

            I found a better way to do this tracking using "find" command instead of "lshistory -mino" that generates huge ammount of log.

            I'm not re-opening this issue but please check linked issue JENKINS-9215 for more details.

            josesa Jose Sa added a comment - I found a better way to do this tracking using "find" command instead of "lshistory -mino" that generates huge ammount of log. I'm not re-opening this issue but please check linked issue JENKINS-9215 for more details.

            People

              raspy Krzysztof Malinowski
              serk1979 serk1979
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: