Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-731

Trend analysis of bugs

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      Mr. Findbugs Bill Pugh has visited Sun and I had a chance to talk with him.

      One of the things he showed me is the tools bundled in FindBugs that let you
      compare two findbugs.xml and then report trend analysis, like how many are
      added, how many are fixed, etc. I think it would be nice to integrate similar
      functionality in the findbugs plugin. He said such correlation feature is
      readily available in findbugs so we should be able to call it easily.

        Attachments

          Issue Links

            Activity

            stephenconnolly Stephen Connolly added a comment -

            It's not Peter, it's me! The issue I raised is MOJO-882 on jira.codehaus.org.

            Peter is the local Ant fan on our site while I am the local Maven2 fan.

            kohsuke Kohsuke Kawaguchi added a comment -

            My bad, Stephen. Thank you for working with the maven findbugs plugin folks.

            drulli Ulli Hafner added a comment -

            Since I'm now using the findbugs library to read the XML files we should
            consider removing the warning differencer (based on equals) with a smarter
            version using the findbugs hash codes.

            drulli Ulli Hafner added a comment -
                • Issue 1576 has been marked as a duplicate of this issue. ***
            scm_issue_link SCM/JIRA link daemon added a comment -

            Code changed in hudson
            User: : drulli
            Path:
            trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/parser/Bug.java
            trunk/hudson/plugins/findbugs/src/main/java/hudson/plugins/findbugs/parser/NativeFindBugsParser.java
            trunk/hudson/plugins/findbugs/src/test/java/hudson/plugins/findbugs/parser/BugSerializeModelTest.java
            trunk/hudson/plugins/findbugs/src/test/java/hudson/plugins/findbugs/util/model/AbstractSerializeModelTest.java
            http://fisheye4.cenqua.com/changelog/hudson/?cs=11653
            Log:
            [FIXED JENKINS-731] Use the unique hash instance of the FindBugs library in equals. Provides a better detection of new or fixed bugs.


              People

              Assignee:
              drulli Ulli Hafner
              Reporter:
              kohsuke Kohsuke Kawaguchi
              Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: