Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-868

serialization problem during collecting findbugs results from slave

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: findbugs-plugin
    • Labels:
      None
    • Environment:
      Platform: All, OS: All
    • Similar Issues:

      Description

      There is a problem with 1.9 release.

      I have a distributed build on slave machine and after build succeseded there
      is an error during collecting findbugs results:
      Collecting findbugs analysis files...
      FATAL: remote file operation failed
      hudson.util.IOException2: remote file operation failed
      at hudson.FilePath.act(FilePath.java:276)
      at
      hudson.plugins.findbugs.FindBugsCounter.findBugs(FindBugsCounter.java:192)
      at
      hudson.plugins.findbugs.FindBugsPublisher.perform(FindBugsPublisher.java:169
      )
      at hudson.model.Build$RunnerImpl.post2(Build.java:138)
      at
      hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:243)
      at hudson.model.Run.run(Run.java:595)
      at hudson.model.Build.run(Build.java:103)
      at
      hudson.model.ResourceController.execute(ResourceController.java:66)
      at hudson.model.Executor.run(Executor.java:62)
      Caused by: java.io.IOException: Unable to serialize
      hudson.FilePath$FileCallableWrapper@a6e74b
      at hudson.remoting.UserRequest.serialize(UserRequest.java:103)
      at hudson.remoting.UserRequest.<init>(UserRequest.java:37)
      at hudson.remoting.Channel.call(Channel.java:263)
      at hudson.FilePath.act(FilePath.java:273)
      ... 8 more
      Caused by: java.io.NotSerializableException:
      hudson.plugins.findbugs.JavaProject
      at
      java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1075)
      at
      java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1369)
      at
      java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1341)
      at
      java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1284)
      at
      java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1073)
      at
      java.io.ObjectOutputStream.defaultWriteFields(ObjectOutputStream.java:1369)
      at
      java.io.ObjectOutputStream.writeSerialData(ObjectOutputStream.java:1341)
      at
      java.io.ObjectOutputStream.writeOrdinaryObject(ObjectOutputStream.java:1284)
      at
      java.io.ObjectOutputStream.writeObject0(ObjectOutputStream.java:1073)
      at
      java.io.ObjectOutputStream.writeObject(ObjectOutputStream.java:291)
      at hudson.remoting.UserRequest.serialize(UserRequest.java:100)
      ... 11 more

      Could you make findbugs specifics classes serializable to avoid such
      probems.

      With 1.8 it works fine.

        Attachments

          Activity

          drulli Ulli Hafner added a comment -

          None of the findbugs classes was Serializable, strange that this operation works
          in 1.8. I'll make the result serializable...

          drulli Ulli Hafner added a comment -

          Fixed in HEAD: FindBugs results are now Serializable. Will be released with 1.10.


            People

            Assignee:
            drulli Ulli Hafner
            Reporter:
            ramazanyich2 ramazanyich2
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: