Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-8806

Build transmission does not work when the transmitter is behind a HTTPProxy

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Component/s: build-publisher-plugin
    • Labels:
      None
    • Environment:
      Running on Native Ubuntu, the war file is used in standalone mode (not deployed under tomcat)
    • Similar Issues:

      Description

      Build publisher works perfectly within the LAN network, and other networks where there are no proxies in between. In a corporate environment, the build publish transmitter is behind a proxy and the build receiver is outside (i.e. a public web server)

      The plugin doesn't seem to use the settings available under the pluginManager/Advanced tab for proxy settings. Verified that the plugin manager is able to connect to jenkins-ci.org to download plugins, so it is not a configuration problem.

      The issue is not resolved even if JVM is invoked with -DproxySet=true -DproxyHost=<proxy> -DproxyPort=<port>. [Even in this case, the plugin manager is able to utilize these settings, while the build publisher is not]

        Attachments

          Activity

          vjuranek vjuranek added a comment -

          Proxy support is added in rel. 1.12. It uses proxy setting from Update center.


            People

            Assignee:
            vjuranek vjuranek
            Reporter:
            svenkatr svenkatr
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: