Uploaded image for project: 'Jenkins'
  1. Jenkins
  2. JENKINS-923

If users removes the view, the polling will not invoke a new build

    XMLWordPrintable

Details

    • Bug
    • Status: Closed (View Workflow)
    • Major
    • Resolution: Fixed
    • clearcase-plugin
    • None
    • Platform: All, OS: All

    Description

      If the users removed the view path, then the polling will throw an exception as
      it can not execute the lshistory in the view path.

      Started on 2007-okt-17 02:01:03
      [hudson_sit_eads_ns_1_daily_view] $ cleartool lshistory -r -since
      16-okt.02:04:55 -fmt '\"%Nd\" \"%u\" \"%e\" \"%En\" \"%Vn\"\n%c\n' -branch
      eads_ns_1 -nco
      Cannot run program "cleartool" (in directory "C:\Hudson\.\data\jobs\Eads Ns1
      Daily build\workspace\hudson_sit_eads_ns_1_daily_view"): CreateProcess
      error=267, The directory name is invalid
      java.io.IOException: Cannot run program "cleartool" (in directory
      "C:\Hudson\.\data\jobs\Eads Ns1 Daily
      build\workspace\hudson_sit_eads_ns_1_daily_view"): CreateProcess error=267, The
      directory name is invalid
      at java.lang.ProcessBuilder.start(Unknown Source)
      at java.lang.Runtime.exec(Unknown Source)
      at hudson.Proc$LocalProc.(Proc.java:80)
      at hudson.Launcher$LocalLauncher.launch(Launcher.java:170)
      at hudson.Launcher.launch(Launcher.java:83)
      at hudson.Launcher.launch(Launcher.java:71)
      at hudson.plugins.clearcase.ClearCaseSCM.run(ClearCaseSCM.java:262)
      at hudson.plugins.clearcase.ClearCaseSCM.getHistoryEntries(ClearCaseSCM.java:247)
      at hudson.plugins.clearcase.ClearCaseSCM.pollChanges(ClearCaseSCM.java:139)
      at hudson.model.AbstractProject.pollSCMChanges(AbstractProject.java:538)
      at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:258)
      at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:290)
      at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
      at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
      at java.util.concurrent.FutureTask.run(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
      Caused by: java.io.IOException: CreateProcess error=267, The directory name is
      invalid
      at java.lang.ProcessImpl.create(Native Method)
      at java.lang.ProcessImpl.(Unknown Source)
      at java.lang.ProcessImpl.start(Unknown Source)
      ... 18 more

      Attachments

        Activity

          redsolo redsolo added a comment -

          Fixed. If the poll is done before the view has been checked out, then a fatal
          message is displayed stating that a build has to be done manually first.

          redsolo redsolo added a comment - Fixed. If the poll is done before the view has been checked out, then a fatal message is displayed stating that a build has to be done manually first.
          abayer Andrew Bayer added a comment -

          Bulk-updating all bugs fixed through 0.8.1 to VERIFIED. Part of cleanup for
          0.8.2 release.

          abayer Andrew Bayer added a comment - Bulk-updating all bugs fixed through 0.8.1 to VERIFIED. Part of cleanup for 0.8.2 release.

          People

            redsolo redsolo
            redsolo redsolo
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: