Uploaded image for project: 'Infrastructure'
  1. Infrastructure
  2. INFRA-1060

SSL Certificate expired on updates.jenkins-ci.org

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Blocker
    • Resolution: Fixed
    • Component/s: hosting
    • Labels:
      None
    • Similar Issues:

      Description

      Since this morning the ssl certificate of updates.jenkins-ci.org has been expired. This blocks installing plugins etc.

      You can validate it here: https://www.ssllabs.com/ssltest/analyze.html?d=updates.jenkins-ci.org

      Valid until	Thu, 09 Feb 2017 03:41:22 UTC (expired 5 hours and 11 minutes ago)   EXPIRED
      

        Attachments

          Issue Links

            Activity

            alkuzad Dawid Gosławski added a comment - - edited

            Kohsuke Kawaguchi is updates.jenkins.io the official new one or just slave ? Docs still mentions old link: https://wiki.jenkins-ci.org/display/JENKINS/Plugins

            fatmcgav Gavin Williams added a comment -

            Not sure if relevant, but I'm still seeing an expired cert:

            max_allan max allan added a comment -

            Still can't update plugins. The massive Java stack trace helpfully tells you when the cert expires but not which server it's for.

            Caused by: java.security.cert.CertificateExpiredException: NotAfter: Sat Feb 09 03:41:22 UTC 2019Caused by: java.security.cert.CertificateExpiredException: NotAfter: Sat Feb 09 03:41:22 UTC 2019 at sun.security.x509.CertificateValidity.valid(CertificateValidity.java:274) at sun.security.x509.X509CertImpl.checkValidity(X509CertImpl.java:629) at sun.security.provider.certpath.BasicChecker.verifyValidity(BasicChecker.java:190) at sun.security.provider.certpath.BasicChecker.check(BasicChecker.java:144) at sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(PKIXMasterCertPathValidator.java:125) ... 116 more
            Feb 11, 2019 12:44:15 PM hudson.util.Retrier startINFO: Calling the listener of the allowed exception 'sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed' at the attempt #1 to do the action check updates server

            danielbeck Daniel Beck added a comment -

            This is a new, different, issue. Being worked on at https://github.com/jenkins-infra/azure/pull/85 but I don't think we have a separate infra issue, I brought it up on IRC.

            danielbeck Daniel Beck added a comment -

            Workaround: Use https://updates.jenkins.io rather than https://updates.jenkins-ci.org in Plugin Manager » Advanced for the update center URL.{{}}


              People

              Assignee:
              kohsuke Kohsuke Kawaguchi
              Reporter:
              christian_heimke Christian Heimke
              Votes:
              2 Vote for this issue
              Watchers:
              13 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: